Cannot connect to VPN with MT300n-v2


I recently purchased an MT300n-v2 device and haven’t had time to really learn much about setting it up for my use until now. In following the directions for setting it up to use a VPN, I am encountering this message, and the VPN service does not start:

OpenVPN 2.4.3 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09 WARNING: No server certificate verification method has been enabled. See How To Guide: Set Up & Configure OpenVPN Client/server VPN | OpenVPN for more info. neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can’t ask for ‘Enter Private Key Password:’. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache. Exiting due to fatal error

In searching the forums for instances of this, I have seen similar messages, but did not readily see a resolution specific to this.

When I imported the file containing the OVPN files, I was not prompted for credentials as the directions said I would be. I had put my .key, .crt, and .pem files from my VPN provider (VPNSecure) into the zip file prior to importing, so I tried again after removing those files and I could not import without them. I assume that there is some method of using SSH to log into the device and start the VPN, as well as set it to load when the device is started, but I am not familiar enough with Linux to know how to accomplish this.

Semi-related, is there a way to install Nano on this device? I’d rather use that for editing config files than vi.


I assume you used PiVPN or something which require a private key password.

first make sure you have the newest firmware.

Then, edit your ovpn files and put one line in the file with content “askpass”

Then upload to the router again. The router will ask for a Private Key Password

Thank you for the response. I tried adding the “askpass” to one .ovpn file and attempted to connect with that one only and it failed. I do not remember any details about what didn’t happen because it was late and I gave up and went to bed. It is now a week later and I have time to spend on this again, so I edited all of my .ovpn files and added that. This time there is no error when it tries to connect, it just goes from “Connecting” to “Not Connected”. I purged the files again and tried using the untouched .ovpn files and again got the error in the attached screenshot.

My VPN provider is VPNSecure (


purge the files, use the edited files to upload again. It should ask for your private key.

Then try to connect again and let me know the result.

I had to reset the device in order to get it to prompt for the password again, as it had the first time when I had only modified a single .ovpn file. This time, as with the second attempt after the directions provided above, I had modified all of the .ovpn files from my provider. When I selected the VPN server, I chose a different one than the one I had during that first attempt with the single file. This time it connected fine. Maybe I did something wrong with that file or maybe it was a bad file and using it initially caused something to be corrupted. I tried numerous different servers from my list of available servers and the result was the same until this time

Coincidentally, I just bought an AR300M and attempted to install the .ovpn files on it and had the same failed result until I tried the modified ones.

Hopefully this will help someone else who encounters this problem in the future :slight_smile: