Cannot get wifi working on old GL-AR300M

I need to get wifi working on an old AR300 but no matter what I do, it doesn’t work.
I have all of the wifi packages installed but there is something in my config that is missing.
I’m missing something but what is it?

Network file is;

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth1’
option proto ‘dhcp’

config interface ‘wan’
option ifname ‘eth0’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’

config interface ‘wwan’
option proto ‘dhcp’
option metric ‘10’

Wireless file is;

config wifi-device ‘radio0’
option type ‘mac80211’
option channel ‘11’
option hwmode ‘11g’
option path ‘platform/10300000.wmac’
option htmode ‘HT20’
option disabled ‘0’

config wifi-iface
option device ‘radio0’
option network ‘wwan’
option mode ‘sta’
option ssid ‘xxx’
option encryption ‘xxx’
option key ‘xxx’

Commands/Statuses;
$ opkg install kmod-mac80211
$ uci set wireless.radio0.country=‘US’
$ uci set wireless.radio0.disabled=‘0’
$ uci commit wireless
$ wifi reload
$ wifi up

Nothing, no new interface showing in ifconfig.

$ wifi status
{
“radio0”: {
“up”: false,
“pending”: false,
“autostart”: true,
“disabled”: false,
“retry_setup_failed”: true,
“config”: {
“channel”: “11”,
“hwmode”: “11g”,
“path”: “platform/10300000.wmac”,
“htmode”: “HT20”,
“country”: “US”,
“disabled”: false
},
“interfaces”: [
{
“section”: “@wifi-iface[0]”,
“config”: {
“mode”: “sta”,
“ssid”: “xxx”,
“encryption”: “psk2”,
“key”: “xxx”,
“network”: [
“wwan”
],
“mode”: “sta”
}
}
]
}
}

Personally I’d try reloading firmware via uboot

Too much work and it’s something simple like config or missing package.

If you reload the stock firmware, you’ll get all the right packages and config files.

Yes true. Maybe I’ll do that but as I mentioned, I believe I have all the right packages, it’s the config that is not right mainly because I cannot find enough information about the default settings.

You need to check the log. It contains useful info of what is wrong with the wifi.

One thing you have to make sure when you use stock firmware wifi works. Someone erased the radio data and wifi will never come back without the radio data.

Check the log? That’s the first things I do when there are problems.
I appreciate the help but I am asking for some technical input and so far, all of the replies are pretty basic things that someone who has never used these should be doing.

I did load a default config and worked from there. I did check the logs. I did search the Internet for two days trying to find a working example.

My problem is as simple as seeing just that, a working config to know what I’m missing or someone to look at what I posted and share what they see that is missing but I have yet to find that.

IIRC, if someone loses the ART partition, RF cal and other useful things are gone

No idea what the last comment means sorry.
The device runs my build, everything works, only the wifi needs to be configured. This is simply a configuration issue. I’m not sure why so many posts are suggesting things I don’t need to do yet.

But log says almost everything. Config does not.

If you say your wifi is not running, there must be something in the log.

How can there be something in the log when it cannot start since it is not completely configured? :).
No, there is nothing in the log, it’s the first thing I check when I have problems.

The moderator might as well delete this post as it is not useful to anyone. I will solve the problem eventually.

Thanks.