Cannot reflash stock firmware on GL-B2200

I have two GL-B2200 devices that I flashed ipq40xx/generic firmware on to test and now I want to go back to stock. The problem is that I can’t get ANY stock firmware image to load via UBOOT. It doesn’t matter - beta or stable - no GL-iNet firmware loads. Now I can only load / re-load the generic version of OpenWRT.

Can someone help me with this? I am at a loss and I fear I will never be able to get these back to stock.

You’ll likely have to install via u-boot

B2200 is covered further down in the page with specifics

That is EXACTLY what I did. Reset into UBOOT, upload stable version for web interface - nothing. Did the same with the beta and snapshot. None of them will load.

I even went so far as to recompile the patched version of UBOOT, found here, and installed and still nothing. The only image I can flash is the generic Openwrt.

Check your uboot - are you configured to boot off spi or eMMC?

(yes, that’s a hint)

I guess I need more of a hint. How do I know? I dont have a serial adapter setup and only have access to the web interface.

I’m still at a loss. I read the debrick page a couple of times and the only specific reference to my mode is this:

  • For GL-B2200(Velica), the two LEDs are blue at first, then turn white to flash 5 times, then turn blue and stay on.

for when you do the reset. I need something else to go on. If missed it - I’m sorry but a hints and treasure hunts aren’t very helpful at the moment. Some specific guidance would be great!

I need the exact link of the firmware you downloaded.

I used the following links to pull the firmware and try to install it:

Any update on the images I used? Right now, I am pretty stuck.


I had to uboot a couple of B2200s today, no problems with loading image.

I did use this firmware here which was given to me by Gl.Inet (use at your own peril :stuck_out_tongue: )

Process (and LED status is from memory because I forgot to write it down when I did it but think this is it).

  1. Disconnect power
  2. Press and hold reset button
  3. Insert power
  4. Top LED flashes blue and then goes solid
  5. Release reset button
  6. Manually set device to
  7. Insert cable into LAN port
  8. Browser to
  9. Load and upgrade

Don’t forget to change your device back to DHCP or to a 192.168.8.x device so you can access the router once it’s rebooted.

3.212-0301 has problems. But I never know it has problem to flash via uboot. If cannot it should be a problem of uboot.

Pls hold on a few days and I need to test 3.212 in more details.

@limbot - thanks for the suggestion!

Gave it a go and no luck. It appears to upload (flashing light) and then reboots and comes back to UBOOT. For the life of me - I don’t understand. Did flashing the OpenWRT 20.02 snapshot break the underlying filesystem?

While I am waiting - If I wanted to try TFTP, do I need to rename the .img file to a specific name (e.g. recover-B2200.img or something like that)?

EDIT: I figured out the filename from the TFTP log. It is asking for “qsdk-gl-b2200.bin”. I’ve renamed the stock and beta versions to accommodate upload and I get the same result - Reboot back to UBOOT. So I can confirm that UBOOT and TFTP yield the same result.

EDIT on EDIT: If I unzip and rename the OpenWRT snapshot (openwrt-ipq40xx-generic-glinet_gl-b2200-squashfs-emmc.img.gz) to qsdk-gl-b2200.bin TFTP takes it and installs it without issue! So - I can reinstall OpenWRT all I want from either UBOOT or TFTP, but I cannot install any of the factory images.

Could you please tell me your email? It requires a firmware recovery partition table .

How do I send you a private message with my address? It seems I can only send messages to employees. I see you listed as a moderator but I cannot find where to send you the message.

Click on the “L” above and you should get:

That’s what I thought - but here is what I see when I click on it:

You have to get to Trust Level 1 on this forum before you can PM:

Get to trust level 1 by…

  • Entering at least 5 topics
  • Reading at least 30 posts
  • Spend a total of 10 minutes reading posts

I do not work for and I do not have formal association with GL.iNet

Thank you!!! I finally was able to send the message.

This recovery partition table worked! I was able to flash the file you sent, then flash back to the stock firmware.

Thank you!!