Can't add new client profiles to wireguard server on GL-AX1800

Set up a new AX1800 yesterday. (fully up to date with software)

Added 1 profile to wireguard server with no problem.

Today I go to add more profiles, click on vpn > wireguard server > profiles > Add
typed in a profile name , hit apply, get popup window “Success!”
only profile showing is one i added yesterday. (refreshed browser to make sure) still nothing added
file /etc/config/wireguard_server still has one user profile (and of course server config)

to make sure not a permission problem, i used the gui to rename the existing profile and that worked just fine. config file shows changes.

wg server working just fine for the one client that is in place.

A bit more info: backed up the config file and deleted the one user profile in gui with no problem. However could still not add anything. put things back and one user profile shows up. still cant add any more to config via gui.

looks to be a GUI problem with adding profiles

I can’t find any error messages anywhere. I would rather not have to hack the config files by hand to add more profiles. HELP

I am not new to GL products, been using others for some time now.

Is your firmware version 4.1.0?
Can you try firmware version 4.2? I have just tested this version and I can add multiple clients.

Yes, running 4.1.0. Just to make sure I didn’t cause the problem, I factory reset router and discovered i could add more than one profile. Looked at configs from fresh load and backup that I made. Turns out I broke things. Although not sure why. Anyway, I had noticed some ipv6 running even though it was turned off in the gui. Tried to stop the ipv6 as I do on any system not using it.
Along with that I noticed that in /etc/config/wireguard_server it appeared that ipv6 was disabled…
per the setting “option ipv6_enable ‘0’”
so i also commented out “option address_v6 ‘fd00:db8:0:abc::1/64’”
Tried the same on a factory 4.1.0 load and that broke the gui. It could see the previous multiple profiles I just put in this morning, but could not add new ones even though the success popup showed.

uncommented option address_v6 ‘fd00:db8:0:abc::1/64’ and restarted wg server again.
This time the gui could add new profiles.

Not sure if gui is looking for that option, or the system is actually using some ipv6 internally even if disabled at user level. It ONLY seems to affect adding new profiles. Deleting and editing existing profiles still works with that option commented out.

I took the time to explain this in detail in case someone else gets overly aggressive in tuning a config. I should know better than to try to clean up/tweak behind the curtains and will be more careful in the future.

Thanks again