Can't connect to Beryl GL-MT3000

I had set up the Beryl a week ago, then unplugged until today. After plugging it in again:
-No Wifi signal
-Can’t connect to router by using LAN
-Can’t connect to the admin panel using the GL App.

Tried to reset with no success. Is this bricked, or am I missing something? How do I get this back to where it is operational?

Please refer to Debrick via Uboot.

The video says to not use “TAR files”, but when I click the link under step one and select the model, “version 4.1.3” appears which is a TAR file.

Is that why after I followed the steps it wouldn’t connect to

Please refer to the firmware download centre for instructions. The installation file varies from model to model, the MT3000 can use tar files.

Accessing has nothing to do with the firmware file.
After you have uploaded the firmware file, the device should reboot and you will need to re-enable DHCP on the client and connect to

So, I followed the steps, several times, and still can’t reach to upload the file through u boot. This is a work laptop…is it possible that there is some company software built in to prevent me from doing this?

I figured it out. Apparently, for this model, the port you use to connect to the router does matter: The WAN does nothing, but LAN worked!