Can't connect to GL-MT300N first time setup page


I bought the above product today and i have spent 4 hours trying to get it to work.

I have a Sky Q hub fibre and homeplugs from router to upstairs pc and smart tv. I followed the instructions on setting up but i could only connect to the mini router by wifi and could browse the web but not from pc or tv.

I had to use laptop wifi to do this.

I have tried to get to the setup page but i cant get the to work.

I want to update the firmware and then put PIA vpn on it but i am struggling to connect.

Any help would be very much welcomed.

Connect to the router using an ethernet cable and try

Thank you for replying.

Can you tell me what ethernet cable goes from where to the router.

I followed the diagram which came with the mini router.

Mini router WAN port out with ethernet cable going to my Sky Q router Lan port.

As in my thread i cant get anywhere with that ip address as it says “page can’t be displayed”


Look here: Overview - GL.iNet Docs

and follow the instructions starting “Now connect your PC to the LAN port or connect via wifi.”

If you want to (eventually) connect to your V router via WiFi, then set-up your GL router as a repeater.

I tried again this morning.

I cant remember what i did but i got to the welcome page and selected English and then i went to flashing mode and after 20 mins or more it was still"flashing mode".

While this was happening it disconnected from LAN and then i turned the mini off and then restarted and all i got was choose English and then nothing happened after 20-25 mins.

I never got timezone or password screens.


Maybe do a reset (with the reset button).

press and hold the reset button for 10 seconds and let the router reset Overview - GL.iNet Docs

Then start again.

This time don’t connect to your main router, only connect your PC to the mini router.

DON’T USE Microsoft Internet Explorer. Use firefox or chrome.


ELI5 and alzhao thank you for the replies.

I done the reset and then connected to the MT300n and the laptop as i can use the pc to check the forum.

It connected and i got as far as putiing in the openvpn files from PIA when i just kept getting error connecting or something like that.

I left it 15mins and when i came back it had disconnected from the MT300n and i couldn’t get any internet from it but on the pc it was ok.

I retried 3 more times and got the same result.

I can’t try the pc as it doesn’t have wifi and if i plug the cable into the mini router there and then to the pc there is no inernet as i use homeplugs which then connect to the homeplug downstairs next to the ISP router.

When i did connect it yesterday i noticed that i had 2 internet access 1 for my ISP SSID and 1 inidentified which turns out to be the TAP window adaptor V9 if that helps.

These are the homeplugs i have

Thanks again.

Just give the error displayed in the UI for openvpn. Thanks. A whole screenshot will be helpful.

Tried again today and no good.

Using Win 10 laptop upstairs as win 7 pc has no wifi.

As the snip shows cannot resolve host address.

Sorry snip did not upload.

Have a search through this thread with “pia”:

I have looked through the forums for “pia” and looked at tons of threads.

I can not get passed putting the OPVN PIA zip files onto it.

A lot of threads say change settings to allow ports/dns on the mini router but i cant find them.

Unless i have got a broken GL-MT300N mini router.


The error is cannot resolve domain names.

Is the Internet connected? are you using repeater and cable at same time but one cannot connected?

ISP’s router is working on wifi and lan/homeplugs.

I followed the instructions that came with mini router but was told to only connect pc to mini router.

I had to use a laptop and got connected and could use laptop wifi through mini router but i got to the setup page but when i put in the PIA OPVN zip i get the errors shown in the screenshot.

In the quick start Overview - GL.iNet Docs i do not have the DCHP listed and wifi is on, port 83 which has not open next to it.

I have not done any changes to these settings.

I managed to get a bit further with the min router.

I have loaded the opvn files on to router and set it to switzerland.

Setup is laptop lan to mini router WAN. Can not connect to internet.

Managed to get DHCP up on settings page but will not connect to internet.

Took mini router downstairs to ISP router.

Pc to homeplug wall socket—downstairs homeplug from wall socket to WAN on mini-----cable from mini LAN to ISP LAN port. Nothing works and can get ISP router setup page or internet.

As i mentioned in 1st post i need to connect upstairs PC and tv through homeplugs going through the mini router.

I have inserted a screenshot of the latest setup if somebody could look at it and give me some advice please.