Can't connect to Hotel Wifi GL-MT1300

This isn’t the first time I’ve been to this hotel and I’ve always been able to connect via repeater option on the MT1300. When I scan and find the wifi network I want to join, I press join and I get a spinning icon for about 30 seconds and then it times out and doesn’t join it just goes back to that same network selection screen and the click to join button. I know it’s not the hotel’s wifi because I have another similar device and it’s able to connect just fine and pulls up the captive portal. I’m on openwrt-mt1300-3.212-041. Idk what’s going on. I haven’t had issues like this until now. I’ve seen similar posts to mine on here, but I’ve basically tried all of them to no avail.

I am not sure exactly the difference but here is the beta 3 which is released on April 7

If it does not work, go back to firmware 3.203.

Repeater was affected because from 3.211 new wifi driver is used and we have been fixing on 3.212.

Thank you. It works now . That version ended up fixing the issue and I was able to connect to the network now. I guess the beta I had on there recently I thought was the most recent one, but I was wrong.

1 Like