Cant connect to wireguard server when Router in repeater mode (Mango)

I’m using Mango router which is connected to my home tenwork via wifi and shares another wifi, so basically router is in repeater mode.

What I want is to connect router to external Wireguard server (not my own, but from provider).

Now the problem:
Wireguard not connecting in this setup! The dot near VPN section in web UI always orange and router just has no internet until I abort the connection.

Strange part:
Wireguard connects and working perfectly with the same config when router connected to internet using tethering from my phone.
Also, I have 0 issues connecting to wireguard with same config from my phone or PC (connected to my main server) using official wireguard client. So my home ISP not blocking wireguard.

I also tried to connect mango to main router with ethernet cable - same result, no wireguard for me.

So looks like wireguard not working only oin the Mango router and only when it’s in repeater mode.

I’m already tried to set DMZ and port forwarding on my main router. So I really can’t understand what is preventing it from working.

Any ideas will be appreciated.

Seems you are saying when connect as cable, wireguard does not work as well.
Can you clarify?

Without wireguard, do you actually have Internet on Mango?
Also check if your wireguard use dns as endpoint or IP?

Mango have internet connection when connected with cable or wifi to the main router.
What is more - OpenVPN works perfectly, but I need Wireguard.

And yes, when Mango connected tot he main router with cable the Wireguard not working as well.

DNS in Wireguard config is an IP, not the hostname, if You mean that.

Can you pm me the config to check?

Sent it to You. But it’s behave the same with several different configs.


check the config it works fine. Seems it only have problems with a particular ISP.

As the ISP environment is not possible to test now, I will wait until it is possible for @udenfox to use that ISP again.