Changing leds on ar750

Hello. I’m trying to change the led behavior for the power led so that it triggers with my vpn. If i use the luci interface the change does not stick after reboot. How can i change this to make it stick? I’ve got an ar750 with the 2.27 firmware.

It should take effect. Did you saved your settings?

It does indeed take effect after i save and apply. The problem is after a reboot it goes back to indicating power and the stock configuration is back.

Only the LED config is reverted or everything?

If it is everything you may need to check if the flash is full.

Sorry, only my single custom led setting is reverted, otherwise I’m loving this. I have more questions, but I’ll deal with this first. I know i read in another thread how to set them ( the LEDs ) using either ssh or a script, but i can find the thread again.

An idea occured after doing a little searching in the os. Can i just add a line into the /etc/board.d/01_leds file? It would look like this:

 ucidef_set_led_wlan "vpn" "vpn" "$board:white:power" "netdev"

But i know some changes need to be made besides the ones I’ve made. Any suggestions are welcome.

Would this work

 ucidef_set_led_default "vpn" "vpn" "$board:white:power" "netdev" "tun0" "tx rx"

Maybe you can just try.
Or you can write a separate script put it in /etc/rc.local
You can every edit /etc/rc.local directly from luci

uci set system.vpn=led
uci set
uci set system.vpn.sysfs='gl-ar750:whitel:power'
uci set system.vpn.trigger='netdev'
uci set'tun0'
uci set system.vpn.mod='link tx rx'
uci commit system
1 Like

I did try my own idea, and several others all with no effect. I’ve now created a script called in /etc. Using this code


uci set system.vpn=led
uci set
uci set system.vpn.sysfs=‘gl-ar750:whitel:power’
uci set system.vpn.trigger=‘netdev’
uci set‘tun0’
uci set system.vpn.mod=‘tx rx’
uci commit system

But it doesn’t seem to work. I’ve also tried calling it through an ssh session, but that didn’t work either. I’ve been at this in between trying to fix vpn issues for 5 days. Oh well. If anyone has any other ideas feel free to comment.

I do have my switch set up for vpn on/off. Looking in the file i see that other models have it set to use a light for vpn with this script. I tried modifying this script with no luck. Is the ar-750 no included there because it just doesn’t work?

Sorry the led name is wrong.

uci set system.vpn.sysfs='gl-ar750:white:power’

This should be dead simple.

AR750 doesn’t have LED for openvpn because it doesn’t have spare LED. This problem is not related to any specific model.

1 Like

Ok, so it is running now with no error in the log, but still no results to show. Is it possible that the led script is running before the vpn is up and is causing it to revert to a default?

Edit: actually i can see the new setting taking effect, after it boots the power light goes off, but it then reverts about the time my wifi connects, less than 2 seconds later

Edit 2:. Ok, turns out the script i was using to reconnect my vpn was running and causing it to reset the vpn. This tells me the light won’t persist after a vpn reset, but that’s ok, it can work as an alert. What i did to fix my problem is just this

(sleep 45;/etc/openvpn/ &

In my rc.local