Cirrus Router Arrived Today and

It seems that I cannot save any of the settings.

Everything works after setting it up via the Gl.Inet interface, but a reboot clears all of the settings. Going into the native OpenWrt interface shows that there are 40+ unsaved settings and clicking apply does not actually save them. The screen appears to be saving, but then still shows the same number of unsaved settings up in the corner.

Since the settings cannot be saved, there is no password and SSH is running on the unspecified interface, so I cannot actually connect this up to the internet until that gets sorted.

Looking forward to some advice.

Seems like something happened with the firmware out of the factory :frowning:

Follow this guide here:

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

There is no information about the LED sequence yet, but try the same sequence as the S1300.

Use the latest firmware from here:

https://dl.gl-inet.com/firmware/ap1300/testing/

1 Like

Hey that worked! Thanks!

1 Like

Hi, my Cirrus arrived today as well. Is there a way for the firmware flash to be done through the GUI? I do not have easy access to an ethernet port on my computer.

I was able to flash the updated firmware using an ethernet dongle and it seems to have solved the problem. I am still having trouble connecting to 4G network but I will follow up on that. Thank you!

Following up here again - I am using Visible SIM and was able to get it working after a bunch of messing around in the AT Commands (very lucky) - excited to see how it works!

1 Like

I am not sure what were the problems but I am happy to see it is working finally.