client does not connect to wireguard

Well, the problem I have is that the client that it takes from the configuration file does not connect to the vpn server and is not detected by the server.
I have tried activating the ddns that in another router that I had I did precisely that and it worked but not in this case.
I have also tried to reset the router to the factory but nothing I am sure is something of configuration.
The listening port has been opened in the operator’s router.
It must be some addressing problem but I can’t get it out.
I have the gl-ax 1800 router.
Thanks in advance for the help

Hello,

  • Please post your device’s current firmware (GL GUI → System → Upgrade)
  • Update your device firmware to the latest stable version
  • Please disable Dynamic DNS/dyndns/ddns; that’s unrelated to WireGuard at the moment & is an unneeded complexity for this issue
  • Who is your VPN server provider (eg: Nord, Mullvad, Surfshark, ExpressVPN, IVPN, etc.) or are you hosting your own VPN Server?