Client mode with WPA enterprise

I’m trying to connect a GL-AR150 with firmware 2.20 to a WPA Enterprise network. To join the SSID, I just need to put in a username and password, but I do not see WPA Enterprise encryption listed as an option.

I have tried the instructions here, Client Mode Wireless [Old OpenWrt Wiki] but I get 255 errors when installing the wpa-supplicant packages and the network never connects.

Please assist.

 

 

OK, I removed hostapd and wpa-supplicant and installed wpad instead. Now I see the options I need to connect, but I am still unable to connect in client mode with all of the fields configured. Any help is appreciated.

the 255 error may not really matter.

Can you post your config? /etc/config/network and /etc/config/wireless

root@GL-AR150:~# vi /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd56:6725:xxxx::/48'

config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option hostname 'GL-AR150-1a1'
option ipaddr '192.168.10.1'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
option hostname 'GL-AR150-1a1'

config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'

config interface 'wwan'
option proto 'dhcp'

root@GL-AR150:~# vi /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option path 'platform/ar933x_wmac'
option htmode 'HT20'
option txpower '18'
option disabled '0'
option hwmode '11g'
option country 'US'

config wifi-iface
option network 'wwan'
option ssid 'hostnetworkssid'
option device 'radio0'
option mode 'sta'
option bssid 'F0:B2:E5:xx:xx:xx'
option eap_type 'peap'
option identity 'myusername@domain'
option password 'mypwd'
option encryption 'wpa2+ccmp'

Additionally, the WiFi scan function eventually dies and will not scan for networks unless I factory reset the router.

I got the client mode to work and then realized what I need is an ethernet bridge. so I’ve posted over on the OpenWRT forum here: OpenWrt Forum Archive

 

I don’t think you need to build a relay on top of EAP wireless network. The enterprise network will automatically deal with this.