CPU Governor on Beryl AX GL-MT3000

Hello!
I just got my Beryl AX and I love it! :sparkling_heart:

I was doing my usual OpenWrt configuration and realized there’s no way to set cpu governor.

It looks like the kernel was not compiled with dynamic CPU frequency control enabled.

Is this an oversight? Does that mean the router is always running at full CPU speed? I power it with a USB powerbank so dynamic frequency could give me more battery life.

I could just install vanilla OpenWrt but I really like your web interface and would rather keep it. Can you possibly enable CPU frequency scaling for me in a future release?

thanks

MTK did not open the frequency control of MT798X. So we can’t compile it.

Thank you for replying so quickly. I will just keep the GL-inet firmware then :slightly_smiling_face: