DCHP with 2 vlan

Hi,

I’m a very noob in network. :slight_smile:
I have a gl-ar750 router.

I want to create new another LAN with another range IP (Exemple 10.10.10.1/24)
I dont’ want this new LAN can be accessed by the actual LAN (192.168.8.1/24)

And also, i want to attach client computer on specific LAN and change it from LAN to another LAN in easy way.

Is it possible with this router?

Below my actual conf

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fded:f2ab:bfbd::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth1.1’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option hostname ‘GL-AR750-9c4’
option ipaddr ‘192.168.8.1’

config interface ‘wan’
option ifname ‘eth0’
option proto ‘dhcp’
option hostname ‘GL-AR750-9c4’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’
option disabled ‘1’
config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 2 0t’

config interface ‘guest’
option ifname ‘guest’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr ‘10.10.10.1’

config interface ‘wwan’
option proto ‘dhcp’
option metric ‘20’

Thank you for your help

I don’t know your topology, but if you just want to set up another LAN, you can refer to the following configuration.

config switch 
	option name 'eth1'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
        option device 'eth1'
        option vlan   '0'
        option ports  '0t 1'

config switch_vlan
        option device 'eth1'
        option vlan   '1'
        option ports  '0t 2'


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd74:c775:cee0::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR750-1b4'
	option ipaddr '192.168.8.1'

config interface 'lan2'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR750-1b4'
	option ipaddr '10.10.10.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-AR750-1b4'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

Thanks, that’s what I was looking for.

I will configure and let you know if there is an issue.

Regards,