Dead 300a - not just dead - really dead


I work with embedded devices for a living. This is a fantastic device and I love it.

I had initially connected a TTL level serial cable to the 3 stake headers and added a microSD card for my shared movies.

I have had excellent results and have repeatedly watched the unit boot and configure itself and yes, I know the cable is fine.

I have setup a variety of shared folders, watched movies off the microSD card, the works. Excellent device.


However I apparently have a totally dead 300a less than 48 hours old on my hands.

This morning, when I turn the device on, the only thing that happens at boot is: a solid power light and solid middle light (the middle light goes off in 1/2 a second and then stays off). There is no serial activity and I have even removed the microSD card that I had been using and tried to boot again. Still nothing. I have also tried the 8 second reset trick with the reset button. Nothing.

Hold reset at boot nothing.

I even went as far as downloading the .bin file off the FTP site on your page and located this file (in the name you named it) on a USB memory stick formatted to FAT32 and rebooted… NOTHING.

Pings via Ethernet to fail.

Does this device have a failsafe method to recover itself? Without any boot or network traffic (Yes, I have used Wireshark to monitor the device and nothing) I am not sure it’s recoverable. I really want to try to resurrect this unit and am looking for instructions on recovery when it’s in this state.

It had been sending warning messages out the serial port about a mtdblock0 (or similar) device having an issue prior to the unit becoming unresponsive.

I am all ears and wish to try to fix this one but was so impressed I’d buy another if I can return this one or get it going. Obviously I opened the unit to insert the card and hook up the TTL cable for diagnostic purposes. I hope that I still get support.

One other unrelated note: I noticed when accessing the web page remotely (through the WAN port) that when you try to switch from the friendly interface to the full interface - it fails with a flashing on the screen and a lack of an ability to show the Luci interface login prompt. You may wish to look at that.

Thanks so much for any support that you can give.



Hi Kris,

Thanks for reporting. So you still have output from Serial. You can post it to check.

About Luci from WAN side. Actually it is denied but we have some bad configuration in web server so it just keep reflashing.



No, nothing out the TTL port since the failure. Yes I had added support for TTL serial… yes it worked, yes I got a failing message I mentioned earlier, I then tried a reboot and it errored out griping about the same volume during shutdown and now won’t do anything at this point.


multiple power cycles…no Ethernet activity…no ping on over wire…dead

Power up with no accessories installed (USB or microSD) only green led for power and middle led on for one second only at boot.


Ideas? I don’t have a hardware ice or jtag to program flash chips.


What at should I do? I ordered another from Amazon, I could return it if we don’t know how to fix it. Help, I’d rather fix it.



The serial should at least output something. Otherwise it is dead.

I suspect that it is burned.

Are you in the US? Can you return to us? Please send an email to service at so we find a way to solve this.