Dimino PI on AR150 CC firmware - problems with usb

I have tried other way - I have used carambola2 and ar150 firmware on my Domino 2.

But both, my ble dongle and usb camera is not recognized (I have installed required kmod-video* modules)

root@GL-AR150:~# lsusb 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Both devices works ok on stock CC firmware i.e. on Vocore or Asus routers.

And here is information about gpio.

root@GL-AR150:/etc# cat /sys/kernel/debug/gpio
GPIOs 0-29, ath79:
 gpio-0   (gl_ar150:wlan       ) out lo    
 gpio-7   (BTN_7               ) in  lo    
 gpio-8   (BTN_8               ) in  lo    
 gpio-11  (reset               ) in  lo    
 gpio-13  (gl_ar150:lan        ) out lo    
 gpio-15  (gl_ar150:wan        ) out hi 

I suppose that usb is unpowered

Here is Solution:

root@GL-AR150:/# echo 6 > /sys/class/gpio/export
root@GL-AR150:/# echo out > /sys/class/gpio/gpio6/direction
root@GL-AR150:/# echo 1 > /sys/class/gpio/gpio6/value

Have you tried OpenWrt CC firmware for AR150, downloaded from here: GL.iNet download center

It has the USB power enabled. Actually I am not sure why GPIO 6 is set to low by default in your firmware.

I see. You want to use Domino firmware on AR150.

Did you user our Domino Patch for OpenWrt CC? Actually in the patch there is code to set GPIO6 to high. If this patch applied, it should works.

You can also directly use our sources, with the patches applied. Here is the file where you can find GPIO6 set to high.