Disappointed that VPN client & server cannot be active together

Do I understand correctly that you cannot turn off AX for 2.4GHz in 4.0?

AX is hardware. It is compatible with AC.

I mean this:
изображение
This is screenshot from 3.x. But 4.x does not allow to set legacy modes without ax, so my old WiFi adapter without ac/ax cannot even discover it. It’s bug or what?

It should discover. Maybe just channel issue? Can you change channel?

Have tried different, no success. I ended up with buying a new adapter.

There appears to be a bug with the Wireguard VPN status. After being connected a while (to WeVPN), the status changes to “vpn.client_starting”.

We’re still connected, and MyIP still shows the VPN IP, so does the WeVPN website, even after clearing cache & using a different browser. It appears to be just a bug with the status.

Stopping the core & starting again fixes it for a little while, but after a few hours the status changes to “vpn.client_starting” again.

There seems to be a new GL-iNet Beta build out here. The ax1800.tar.gz file needs to be extracted fully. Have not tested it myself.

2 Likes

@alzhao could you start pushing the V4 snapshot to the download center? Easier to keep an eye out there for new snapshot updates🙏

3 Likes

Pls check now
https://dl.gl-inet.com/?model=ax1800&type=beta

1 Like

Perfect! Thank you very much🙏

Your bandwidth should be set to 20ghz for legacy devices this should allow it to discover.

1 Like

Implement the fixes posted here. I just implemented these and made an account to send kudos to the poster. It works as my PiHole DNS entries are working correctly now when connected to the router.

Any update to fix the vpn policy based routing? I see there has been may updates to GL-AXT1800 Slate AX firmware but nothing for the flint in a while.

1 Like

Make sure to check the GitHub for the latest version:

1 Like

Can you specify? I find a post you made 2 years ago but not sure if you mean that one.

Just open a new thread. Sometimes I miss something, so please just re-twitte the thread.

I am testing ver 4 beta release 2 on my AX1800. I cannot run vpn server and client at the same time. you can turn both ON but you can only use one.

The use case I have is, I want to setup a wireguard client to connect to a Mullvad server in order to proxy all my internet traffic through it. At the same time, I want to run a wireguard server on flint so that i can connect my beryl to proxy all its traffic through flint to mullvad. Can we have this capability in Ver 4.0?

What I noticed is, when the vpn client is running and you turn ON your vpn server – the WG server IP changes to the Mullvad IP instead of your own public IP. its makes it impossible to establish connection at that point. I think what needs to be done is bypass WG server all together from WG client vpn to make this work.

2 Likes

Why cannot you just set up Mullvad on the Beryl as well?

You need to use vpn polices. In your case, just use route based and set up the route manually.

Any chance you give a breakdown on that?

I left the house with the OpenVPN client connection on. I am still able to establish a connection with the OpenVPN server, but I have no internet access or LAN access.

route based vpn policy didn’t help fix the issue. I am still seeing WG client public IP as my WG server endpoint IP


Why cannot you just set up Mullvad on the Beryl as well?

  • Not just beryl, I want to connect any device to my home wg server to go out to Mullvad or to have certain domains bypass mullvad .**

My use case is , I will be traveling and working remotely - My company VPN doesnt work with Mullvad or any vpn as my company restricts traffic from any anonymizers(VPN providers). I bypassed my company vpn domains on flint to make it work at home. when i’ll be traveling, I’ll connect my work laptop to beryl - the idea is to send all my traffic back to my home router(flint) via site to site vpn. based on domain bypass policy set, I want my company vpn traffic bypassed.

This is mine

Use customized routing rules
Wireguard client connected
Wireguard server started

The WG server is using my pub IP. Not vpn IP.

Then you should be able to set up custom routing for WG client and Server. I think this is complicated though.

1 Like