DLNA problem

I have a raspberry pi that runs a minidlna server.
when I connect the pi to my slate the dlna server is not visible on the local net.

If I connect to my asus router everything works fine so the dlna server works fine.

what can cause the dlna server to not be visible when connected to the slate ?


Does the network topology look likes this?

yes, the pc is actually a s5e tablet running vlc.

the dlna server is visible locally on the pi and if i replace slate with an asus 88 router.


can you please try and reproduce this problem.
I cant figure this out on my own.
I run 0626 testing fw btw.


Not sure what is happening.

I tested it just now. My iPhone( connected to AR750S, my PC( also connected to AR750S.

I run a DLNA server(UPNP Xtreme) on my iPhone, Windows10 support DLNA by default, it can discovery the DLNA server automatically.

As you can see, I capture the traffic, it can receive the SDDP packet.


Does your raspberry pi have multiple network interface?

no, its a new raspberry pi 4 with standard raspian os connected to slate via a ethernet cable.
nothing fancy.

ok, this is weird.

I pulled the ethernet cable and connected to slate via wifi, suddenly dlna started working.
test again with same result.
Pi connected to slate via ethernet does not work, connected via wifi does work.

Not sure if the problem is with the pi or the slate.
Can you do a test when connected via ethernet and see if it works for you?


For my testing, my iPhone connect to Slate via wireless, my PC connect to Slate via Ethernet.

Stupid question, you connected Pi to the LAN port of AR750S right?

yes, it is connected to middle port, internet is working from pi.