DNS Leaking with OpenVPN


#21

I purchased a GL-MT300A (256MB) and I have not found it to be leaking any IP or DNS info. I have been running 2.22. I’m not sure this is an issue with the product.


#22

I don’t think thats the right attitude to have alzhao. Il describe the problem to you so you can understand how to fix this. I understand how everyone is feeling, and I too will be returning this item on Amazon if it is not fixed within the week as it has been miss sold.

To recreate the problem:

I have input my open vpn info as a file, and input two new DNS’s into the custom DNS section.
All is fine and no DNS or IP leaks on ipleak.net

But, if i pull the power to the device and switch it back on, the custom DNS settings are still there but not active until i press confirm again in that section. The custom DNS is ignored every time I power down, then back up the router.
It seems to be that the custom DNS needs to be applied/confirmed every time upon boot up, and then this will fix the issue.
You can do this manually, but its very counter intuitive and is obviously an error.
Basically if the device was always on there would be no issue, but as soon as it restarts there is one and you need to reconfirm the custom DNS.

Does that make sense? Hopefully it does, and you can add it to the firmware as part of the boot up of the device to reconfirm the custom DNS settings.


#23

@opticon12000, thanks. This is helpful and we will check immediately. The first time someone mentioned restart.


#24

@opticon12000, can you please tell me what model and firmware version you are using?


#25

I am using the GL-AR300M with the latest firmware update via the device itself (2.20 maybe?). Im trying to use this with Private Internet Access and their DNS’s found on their website.

The reason for using this device as such is so I can secure all my devices, and my friends devices at once, rather than installing an app on every machine.
Only one thing at the time of testing was connected though, my mac, tested on ipleak using Safari.


#26

FYI, I have sent this item back today. Not just because the device is leaking the DNS (I believe you can fix this), but because it was currently stuck at the flashing screen after resetting. Il buy it again from you once the DNS issue is fixed and probably upgrade the device for one with a better ariel too at the time.


#27

*2.20


#28

I am sure The DNS leaking problem is fixed in the most recent firmware. It is still in testing folder and not released. Stucking in flashing screen may be just a l little problem.


#29

Yes it seems to be stuck in a boot loop on that flashing screen after choosing a language.


#30

Maybe pressing F5 or clear browser will solve this problem


#31

I tried this, even tried it on new devices and it was stuck. Even tried resetting it again. I feel like it needs a cable in the side to re-image it completely, but id have no idea how.


#32

I still have the leaking DNS issue, even using the 2.23-7 firmware. Testing on https://ipleak.net/ Any way to fix? Is there any helpful info I can provide?


#33

@opticon12000, can you try http://www.gl-inet.com/docs/mini/firmware/ and http://www.gl-inet.com/how-to-enter-the-uboot-web-ui/ ?

@pixelbit, can you tell me your setup? which openvpn provider? Have you setup custom dns?

 


#34

@alzhao it is AirVPN, Aside from the VPN, It is a fresh install and default settings. The model is AR300M, connecting to the internet through a wifi router. I have tried both latest 2.2 main release and 2.23-7 test firmware, but DNS always leaks. I have not configured custom DNS - should I do that, and where exactly do I find that option in any case? Thanks.


#35

@alzhao Just to clarify my post above - the AR300M is behind another router and I am getting the front router’s DNS, not the DNS of the VPN running on the AR300M.


#36

@pixelbit, you need to configre a custom DNS. You can find this option in Internet Status. http://www.gl-inet.com/docs/mini/internet/#custom-dns


#37

Hi,

I can confirm AR300M DNS leaking. I tried to use Smartdns without any effect. I use the mini router behind a main router in Wisp mode, maybe this could be the cause?


#38

@nikor, which firmware are you using? Can you upgrade to the newest?


#39

Hi,

I’am using 2.22 firmware, isn’it the newest?

Thanx


#40

v2.24 is the newest. It will be moved to devices own folder soon.

http://www.gl-inet.com/firmware/testing/