Double router port forwarding for VPN [GL-MT1300]

I’ve purchased 2 Beryls to set up as a server and client for a VPN using WireGuard. I’ll be taking the client Beryl with me abroad to tunnel to the server Beryl I’ll be setting up on my home network. I’m not technically well versed in any of this and would really appreciate it if someone could provide input.

I’ve gotten the Beryl I’ll be using as a server connected to my home internet via an ethernet connection to my main router. I’ve followed the available tutorial on for setting up a WireGuard server and I then tested the VPN using my phone, but it is not working. I suspect I need to set up port forwarding on my main router as noted in the tutorial - however, there’s not much detail into how to do that. After reading some guides and watching some videos I could find on general port forwarding, I’m still confused. I also think there’s more that I’ll have to do beyond just port forwarding, such as ensuring a static IP address, though again I’m not sure about that.

Would anyone be able to provide instructions on all of the activities I’ll need to carry out on both my main router and my VPN server Beryl to facilitate this? The biggest problem I’ve identified so far is that I don’t know which ports to use for port forwarding on my main router since no guides or videos I’ve watched seem to address specifically where these come from or where I should be looking to find them.


The default Wireguard Port is 51820/UDP. It is important to choose UDP, TCP won’t work. You’ll find it easy by searching for ‘wireguard port’ with your favorite search provider, for example google.
If you’ve set the port to something different, you need to change it.

In addition to port forwarding on your main router, you need either to get a dedicated public IP address from your ISP, or to enable DDNS on the router via Admin Panel → APPLICATIONS → Remote Access. If you use DDNS, then edit the client config file generated by WireGuard Server to replace the Endpoint numeric-type IP address with the DDNS domain name.

I do not work for and I am not directly associated with GL.iNet