Dual WAN configuration of GL-B1300

I have seen in some posts that it could be possible to manage a Dual WAN configuration using mwan3 package, so I am trying to configure a second WAN port on the router GL-B1300 changing one of the two LAN ports to enable a second WAN port in addition to the initial single WAN port (eth0).
Following some examples shown in OpenWRT forums, I have tried the following procedure:

  1. In the Switch page I have added VLAN 3 and VLAN 4; I have moved the Port 3 (the left side LAN port) from VLAN 1 (setting “off”) to VLAN 4 (setting “untagged”), and I have moved the Port 5 (the original WAN port) from VLAN 2 (setting “off”) to VLAN 3 (setting “untagged”). Furthermore I have set “tagged” for VLAN 3 and VLAN 4 in the column of the CPU port.

  2. I have added the Interface WANB and configured in the tab “Advanced Setting” the parameter “Use gateway metric” 10 for the original WAN port, and 20 for the added WANB:


  3. I have configured in the tab “Physical Settings” the Interface VLAN Interface “eth0.3”, for the original WAN port, and “eth0.4” for the added WANB:


  4. I have configured in the tab “Firewall Settings” the firewall-zone “wan” for both the original WAN port and the added WANB:


  5. I have configured in the tab “General Setup” the Protocol “DHCP client” for both the original WAN port and the added WANB:


The result shown in the Interface page is here below:

The original WAN is apparently working because it get the relevant IP address from the Internet router, and it is possible to surf all the web pages from a PC connected to the remaining single LAN port the one at the center of the GL-B1300 (the Port 4 shown in the Switch page), but, when I move the ethernet cable coming from the Internet router from the WAN port to the WANB port (so from eth0.3 to eth0.4), no IP address is assigned with the DHCP server of the Internet router to the WANB port, and it is not possible to surf any web page from a PC connected to the remaining single LAN port. If I move back the cable to the WAN port (eth0.3), the Internet connectivity is reestablished.

Could someone indicate what is wrong in the configuration that I applied ? (at every step I have obviously pushed the button “Save & Apply”).

Thanks

I’m not an owner of GL-B1300 but I see a thing I don’t understand.
How can it be possible that physically the B1300 has only 3 lan ports but I see in your Switch page you have 7 Ports. I don’t know, I’m not an expert, That’s ok.

For no receive IP from WAN-B:
I see that WAN is eth0.3 in Port 5 and LAN cable is connected and it works, but VLAN 4-eth0.4 is linked to Port 3 and no LAN cable there. May be you have to change Untagged in VLAN 4 to Port 4?

The Qualcomm SoC has an embedded 7-port switch, but only Ports 3, 4, 5 have external Ethernet ports:

.
By default, Port 5 is WAN, Port 4 is LAN 1, Port 3 is LAN 2

I do not work for and I do not have formal association with GL.iNet

1 Like

Thanks for pointing to the page [OpenWrt Wiki] GL.iNet GL-B1300 where it is stated °Sadly it’s not possible to do this from the switch configuration page in Luci Web interface, it must be done manually°. Therefore the issue that prevent the Dual’WAN configuration I posted above is due to the fact that I have tried by using the Luci Web interface, while it should be done manually. The question at this point is: how it should be done?
In the above mentioned web page the modified network file to split the two LAN ports and use independently is shown. After doing that, how could one of the two LAN ports that are so configured to be used independently could be used as second separate WAN (let’s call it WANB)?

Instead of what is shown in the above mentioned web page:

config interface ‘newinterface’
option proto ‘static’
option type ‘bridge’
option ifname ‘eth0.4’
option ipaddr ‘192.168.99.254’
option netmask ‘255.255.255.0’
option stp ‘1’
option igmp_snooping ‘1’
list dns ‘1.1.1.1’
list dns ‘8.8.8.8’

I would change the section of the network file in the following way:

config interface ‘wanb’
option proto ‘dhcp’
option type ‘bridge’
option ifname ‘eth0.4’
option stp ‘1’
option igmp_snooping ‘1’

Furthermore I wwould assign such new interface to the ‘wan’ firewall zone.

Is my understanding correct?

OK thank you.

Now I see that I looked at the image wrong and as you said Port 4 is already the LAN.
I just looked too quickly to see that Port 3 doesn’t have any cable in it, at the time the image was taken… so what I said above doesn’t make any sense.
Apologies.

About your config file I think that should be like that if you want to have IP from DHCP router “B” server

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config interface ‘wanb’
option ifname ‘eth0.4’
option proto ‘dhcp’
option hostname ‘wanb’

config switch_vlan
option device ‘switch0’
option vlan ‘4’
option ports ‘0t 2’
option vid ‘4’

I made this in AR750S, so I don’t know if the section option device ‘switch0’ is the same in B1300.
Also I don’t know if LAN Ports are in this order 0 1 2 in B1300

I used WinSCP to get into and edit config/etc files.

I’m not an expert…

Thanks David,
I’ll test your suggestion.

I am not expert also. I think WANB is on VLAN 4 and Port 3, according to the OpenWRT page:

config interface ‘wan’
option hostname ‘GL-B1300-WAN’
option proto ‘dhcp’
option metric ‘10’
option ifname ‘eth0.3’

config interface ‘wanb’
option hostname ‘GL-B1300-WANB’
option proto ‘dhcp’
option metric ‘20’
option ifname ‘eth0.4’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘1’
option description ‘lan’
option ports ‘0t 4’

config switch_vlan
option device ‘switch0’
option vlan ‘3’
option vid ‘3’
option description ‘wan’
option ports ‘0t 5’

config switch_vlan
option device ‘switch0’
option vlan ‘4’
option vid ‘4’
option ports ‘0t 3’
option description ‘wanb’

Also confirm that Firewall WAN zone includes WAN and WANB and reboot the router after making changes.

Make sure to backup the router settings before making changes.

I do not work for and I do not have formal association with GL.iNet