E750 ethernet replicator

Hi There
I’m trying to use the E750 mundi ethernet replicator with another usb-c – usb-c cable than the one provided by the bundle.
I have so many usbc – usbc cables that i decided to travel without the provided one.
I’m trying to set up a lan ethernet client but I see no other explanation why it is not working for me

Any help appreciated
Than you

I know with USBA to micro cables, some cheaper cables support charge only and not data. Not sure if it’s the same with USB-C to USB-C?

Thanks for the reply
That could explain. When I have the router with the ethernet port replicator AND my spare usbc – usbc cable, the router is charging BUT there is no data
I thought all usbc cables are for power and data…

As I menitoned I know I’ve had this problem with Micro and am not sure if the same exists with USB-C. Just a possible thought/explanation.

It should work with standard type c cables. But have you tried the original cables before?

I am using it as lan and here is how it output for “ethtool eth0”


Thanks for you time
I’ve never tried the original usb-c – usb-c cable; I regret now. I packed my stuff to travel and had two usb-c – usb-c, one from a ThinkPad and another from a Macbook pro. I tested the router usb-c/lan port with the replicator with both cables. The link is always down.
Any suggestion is highly appreciated, thanks!

ethtool eth0:

followed by ip link show eth0 and dmesg | grep eth0:

Can you show the content of /etc/config/network?

The eth0 seems up and down. If it is not wrong config, it must be the cable or adapter problem.


Content of /etc/config/network:

The config seems OK.

I just tried another type-c cable and the connection from pc to replicator to mudi does not work at all.

Changed back to the original one and it works. There must be some wire problems I think.

OK update. TypeC cable has many wires inside.

Charging cable may not have some wires so it may not work with E750.

Thanks for testing with a different usbc cable.
As soon as I’m back home I’ll try with the original cable.
I’m really confused as I thought all usbc are capable to transfer data and power.
Why would GL-INET design a product working only with a very specific type of usbc?

If GL could provide the information of which type of usbc this Mudi router is using to connect to the lan port, I’d really appreciate.

Thanks again

All USB-C cables “should” be the same but in reality they are not. In order to cut corners, some manufacturers ship “charge only” cables to minimize the material cost. These “charge only” cables lack the data exchange wiring inside them.

1 Like

As @Bpz1970 said, its is not our problem.


Of course all of these is not your problem. Just trying to figure out a workaround solution that may also help others.
I bought this router because I travel a lot, and if I was to carry all the usbc cables of all the hardware I travel with I’d have an extra bag.
I also understand that manufacturers try to cut corner, but if there is one model or brand that could replace them all I’d happy!

Thanks again for you support

Every manufacturer makes different USB-C cables to meet different specifications and for different use cases. The USB-C specification is for the connector and the cables may vary.

I buy USB-C cables from Amazon and only buy the quality cables (i.e., more expensive). In the product description, I look for:

  1. USB 3.1 Gen 2 (minimum 3.0 Gen1)
  2. PD (Power Delivery) 100W (minimum 60W)
  3. Fast charging
1 Like

Old thread but I just wanted to share. I gave up on the E750 replicator, it either is dead or only works with the exact USB C that it came with. Unfortunately I lost that so I just gave up on it. Fortunately I just picked up one of these on amazon. TP-Link UE300 V4 https://www.amazon.com/gp/product/B00YUU3KC6

This uses the RTL8153 from what I could find via google, however I installed the RTL8151 and RTL8152 drivers and the dongle was recognized as ETH1.
Once you have added this to the hotspot as ETH1, you just have to add that to the LAN interface via LUCI. Just go to “Network” then “Interfaces” and edit the LAN. Go to Physical Settings, and under the “Interface” pull-down, check the ETH1 interface to add it. You should then be able to hook up any ethernet device and get a dynamic address.