E750 Mudi - Repeater Disconnects from Upstream WiFi

Recently purchased a GL.iNet E750 Mudi. It has been upgraded to the latest firmware (3.201) and factory reset. It’s currently set to router mode with the repeater function enabled. It works well for a couple of hours, sometimes more, but then it drops the upstream WiFi WAN connection entirely. The only way to fix it is by doing a full reboot or logging in to the web interface and manually reconnecting to the upstream WiFi network. Holding down the reset button for 3 seconds does not fix it. The repeater is set to scan/reconnect automatically. I’ve tried different wireless bands, moving the Mudi right next to the WiFi router, etc.

I’ve also tried disabling the gl_health service as suggested in other posts, with no luck.

Here is a link to the system log messages that occur once it disconnects: GL.iNet E750 Mudi - Disconnects - Pastebin.com

An email has been sent to the support team as well and I will post back here if they provide any useful information.

Have replied you via email.