Hello there :slight_smile:

I tried astrorelay to access an HTTP service on my local network, so i set up an astrorelay url.
When i use HTTP, i can access the service through the astrorealy url.
But when i use HTTP TO HTTPS, the browser keeps displaying ERR_EMPTY_RESPONSE.

Any idea ?

Could you check the client’s status of your agent? Please make sure it’s connected.

Yes it is enabled.
I tried with HTTP only and that works as expected.

It’s only HTTP to https that has an issue.

It should be worked if your client’s status were connnected.

Try with incognito mode or other browser like edge,firefox etc.
If it still didn’t work, you can give some screenshot of your agent.

Tested with inprivate mode only:



Your link url should be like https://xxxxxxx if you choose HTTP to HTTPS. It start with https not http.
So I guess you maybe mistake it. I tested and got the same error if use http way to visit the url of HTTP to HTTPS.

You could check it like below, the link urls of HTTP and HTTP to HTTPS are not the same.

I use this link.


As soon as i paste it in the browser, it redirects to an HTTP link.

Oh i understand what’s happening.
The target web page redirects to a local HTTP url (instead of https), and astrorelay does not rewrite the URL with HTTPs


Your local server should not do any rewrite or redirect which could broke the connection.

Ok. It’s a proprietary app from a publisher and i don’t control it.

Then you can just use http