Error compiling program

I’m trying to compile openssh-client but I’m stuck at this command make toolchain/compile V=s. An error always shows up every time I run that command even though I have installed all the required packages at it’s been more than 4 hours now that I’m trying to compile that package. I want the latest version of openssh-client that is OpenSSH 7.2p2. Can someone please compile openssh-client v7.2p2 for my Gl.iNet 6416 running OpenWrt BB ?

what is the error?

package/Makefile:171: recipe for target ‘/home/pb/Desktop/carambola/carambola2/staging_dir/target-mips_34kc_uClibc-’ failed
make[1]: *** [/home/pb/Desktop/carambola/carambola2/staging_dir/target-mips_34kc_uClibc-] Error 2
make[1]: Leaving directory ‘/home/pb/Desktop/carambola/carambola2’
/home/pb/Desktop/carambola/carambola2/include/ recipe for target ‘world’ failed
make: *** [world] Error 2

I had no problem when compiling openwrt trunk but somehow I keep running into this when I compile openwrt BB

Have you ever compiled openwrt successfully?

Have you ever changed the path after you compile?

I suggest to do a make distclean to start over. This will remove everything and recompile.

Hi @alzhao thanks for the reply, I’ve decided to stop with BB, instead I’ll compile CC since everything is more up to date in this version but I run into another problem, I’ve made a thread in the openwrt forum but there’s no reply yet, here’s the link to the thread I just need to compile two packages for my GL.iNet CC, they’re corkscrew and sshpass. Can you help me find out what’s wrong or compile those two packages ? Sorry if I’m asking you too much, I really wish I could compile everything all by myself but I always run into that kind of problem, I also have installed all the required packages on my manjaro but it doesn’t solve the problem.

I have done make distclean and start everything over, two times in fact, but it still gives me the same error.

Maybe you can start a totally new build according to here: GitHub - domino-team/openwrt-cc: openwrt CC with Domino/GL patches

These are some errors I cannot tell the reason.