Error installing kmod-usb-serial on mt300n-v2

I am trying to install kmod-usb-serial on mt300n-v2 but got the following error:

root@OpenWrt:~# opkg update
Downloading http://download.gl-inet.com/releases/kmod-3.0/ramips/mt76x8/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_core
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/base/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_base
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/gli_pub/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_gli_pub
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_packages
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_luci
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_routing
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_telephony
Downloading http://download.gl-inet.com/releases/packages-3.x/ramips/glinet/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_glinet
root@OpenWrt:~# opkg install kmod-usb-serial
Installing kmod-usb-serial (4.14.63-1) to root…
Downloading http://download.gl-inet.com/releases/kmod-3.0/ramips/mt76x8/kmod-usb-serial_4.14.63-1_mipsel_24kc.ipk
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial:
  • kernel (= 4.14.63-1-f9abae908ec5e77c3e31aae913709963) *
  • opkg_install_cmd: Cannot install package kmod-usb-serial.

The firmware image I flashed on the device is gl-mt300n-v2-3.0-1011_clean.bin. I am using this version because I also need monitor mode on this device.

Any suggestions? Thanks in advance!

If you need clean firmware, maybe you can just download from openwrt’s website.

I am not sure which one is for the mt300n-v2. Can you kindly provide the link? Thank you very much!

Sure here you are.
https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/

Thank you very much. Your support has been wonderful!