Extroot on Beryl (GL-MT1300)

I did according to the instructions on the extroot openwrt wiki page.
On USB, I was able to do it without any problem.
I can’t do it on a microSD card.
Log reports that UUID does not match.
Please help :slight_smile:

Have you tried different MicroSD cards? Does your MicroSD card has multiple partitions?

I think on the mt1300 the sd card is listed as /dev/mmcblk0p1

I’m about to try it myself so I’ll report back

It would be very nice if you would try it out. I used the path you mentioned in the post.

1 Like

The problem was the microSD card. It is damaged and I am sending it under warranty. Interestingly, on the raspberry pi it worked without problems.

I tried several times and couldn’t get it to work. Corrupted and reformatted the sd card a couple times also. After further reading it seems this is our problem.

  • If you are putting the extroot on a non-USB device such as a mmc card all modules needed acccess the device should be in appropriate file in /etc/modules-boot.d. For example using a sdhci card on a mt7688/mt7628 device /etc/modules-boot.d/mmc needs have two lines added:

mmc_core
mmc_block
sdhci
mtk_sd

Maybe @alzhao could chime in with some help?