Feedback on the new 4.x firmware for Convexa-B (B1300)


First of all, congratulations for the Gl.iNet team for keep developing their devices and the hard work. I started to think my Convexa was forever forgotten on the OpenWRT 15.x version because of the QSDK thing, but I see you are working on a “version 4.x” of your firmware with OpenWRT 21.x, thank you very much for your work, it makes me to trust a little bit more your devices on the future.

I just tried the latest beta (4.3.6 beta 2) on the device and I have some feedback if you need it, maybe some niche things but maybe useful for you.

  1. In the 3.x firmware I can use the “WDS” network mode just fine. On this new 4.x it seems the router can’t connect and I have to factory reset it because it “bricks” (it doesn’t connect to the network and can’t access via ethernet to admin web)

  2. When searching for wireless networks (for WDS, extender or repeater mode) the “scanning” seems strange, as in at first, it doesn’t show all the networks. I have my wifi just at 1 meter, and the Convexa doesn’t show it on the first search. When I click on refresh, it doesn’t seem to really search again, showing the same results for about 10-15 seconds, when it searchs for real again and then boom: there it is my network

  3. I don’t know if this is OK, but on extender mode, the “IGMP Snooping” options disappears, wouldn’t it be there if on WDS (in the 3.x firmware) is there?

  4. When trying to disable DHCP, I go to lUCI, go to the br-lan interface and check the “disable DHCP on this interface”. But it does nothing, the Convexa keeps giving 192.168.8.x IP addresses (what I tried to acomplish is for the router to “give” its connected devices access to the DHCP of the main router on the 192.168.1.x range)

I for now can’t keep using it, as I use this router as a “wireless to ethernet” adapter for a IPTV device that doesn’t have wifi, and I need it to give this device access to the DHCP/IP range of the main router and activate IGMP Snooping. With the 3.x firmware, using WDS mode + IGMP Snooping it works great, but on the 4.x I couldn’t make it work.

But great work! Hope this device can keep living for a long time with the new firmware,

Thanks Gl.iNet :smiley: