File Sharing Blank GL-AX1800

Anyone know why my File Sharing Apply Button don’t work, I have reinstalled the original firmware to factory settings to see if it brings it back but no joy.

The Apply button is blank because there is no Current Directory entered yet.

Do you have a USB flash drive plugged in? If so, it has not been mounted for sharing. Use the LuCI UI, System → Mount Points to see what is currently mounted and/or to mount a USB flash drive.

Thanks I will have a look later, whew is it in LiCI, it’s not under devices

You may have to install the block-mount package, if it is not already installed. After that, you should have Mount Points under the System menu.

Any idea what this about


Ok update after a restart

Tried mounting still shows the same in file sharing never had to do this before whic I don’t understand

Can you run the following commands in SSH and post the resultts, which will show your USB drive has been detected and its UUID? It should also show what storage has been mounted:

block detect
block info
ls -l /dev/sda*

Hi thanks for the help here is the result.

Can you confirm that the following packages are installed and install them if they are available:


I don’t see the USB flash drive in the output. Can you try plugging in a different USB stick that is formatted to FAT32?

Also, run the following commands in SSH, in addition to the previous commands above:

lsusb -t

These don’t even show as plugins


The usb I have plugged in is formatted in EX4

The GL-AX1800 is based on an older version of Openwrt, which may not have those packages. The lsusb command is in the usbutils package, which would displayed everything that is connected via USB to the router.

For EXT4 format, you have to install kmod-fs-ext4 package, if not already installed. For exFAT, you have to install kmod-fs-exfat package, if not already installed.

As a test, you can just reformat the USB flash drive to FAT32, which is the most common.

Another USB formatted in FAT32

NTFS formatted Corsair flash voyager GTX 128 Gig drive mounted using GL-iNet GUI after update. no issue

I still don’t see the USB flash drive. For some reason, it looks like the router is not recognizing it, which could be a firmware problem, or even a hardware problem. Maybe someone from GL.iNet can help figure it out.

For comparison purposes, I have a Sandisk USB drive in FAT32 format plugged in to show what I had expected and hoped to see in your output. It shows up as /dev/sda1 and is mounted as /mnt/USB. This is on a GL-MV1000W, but should be the same on a GL-AX1800.

How about this

Still don’t show anything using the
lsusb -t

I went back to the first firmware and than updated to 3.208
Now you know why i gave up on the AdGurard on the USB i still cant find the USB physically using WinSCP, + could not get my head round creating a symbolic link.
But thanks for your help it is appreciated, very kind of you

This is much better!

Your USB drive is now recognized on /dev/sda1. You should be able to add a mount point in LuCI → System → Mount Points by selecting one of UUID 7078-B4E6 or Label USB DRV or Device /dev/sda1. You can choose a mount point name like “/mnt/USBDRV” or whatever you want and set Mount Options to “rw”, then click the Save & Apply button.

To finally share the USB drive, you can go back to GL.iNet → APPLICATIONS → File Sharing and hopefully, “/mnt/USBDRV” will be available in the Current Directory field. Alternatively, I prefer to use LuCI → Services → Network Shares, which requires the luci-app-samba to be installed first.

Since you do not have the usbutils package, you will not the have the lsusb command available.

The symbolic would be created in SSH.

Try installing all 3 packages

I have the same error message.

/usr/lib/lua/luci/dispatcher.lua:433: Failed to execute cbi dispatcher target for entry ‘/admin/system/fstab’.
The called action terminated with an exception:
/usr/lib/lua/luci/cbi.lua:311: Unable to read UCI data: fstab
stack traceback:
[C]: in function ‘assert’
/usr/lib/lua/luci/dispatcher.lua:433: in function ‘dispatch’
/usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

I noticed that we both have a blank space in our filesystem labels and mount shows:

/dev/sda1 on /mnt/My\040Passport type ext4 (rw,sync,relatime,data=ordered)

Maybe this is the reason why the fstab can’t be created in luci.

I forgot to note that you have to turn on “Enabled” in the LuCI settings for mount point /mnt/sda1.

Have you tried setting the mount point name to “/mnt/MyPassport” with no blanks? The Mount point name can be different from the Label on the USB drive. Also, turn on “Enabled” in the LuCI settings.

It is safer to avoid blanks in general, which is why I suggested “/mnt/USBDRV” above, instead of “/mnt/USB DRV”.

For the EXT4 format on your USB drive, check that the kmod-fs-ext4 package is installed.