File sharing on MT1300 4.3.6 firmware

In the release note of 4.3.6, it said no file sharing UI anymore. I installed samba4 and able to see router from other devices, but getting trouble on mounting my sdcard using ssh or LUIC (I enabled /mnt/mmcblk0p1 mount point in LUIC but didn’t show up in ssh shell)

Is there any documents or tutorial?

Will file sharing configuration UI be back in new version?


1 Like

What file system is the sd using? IIRC, exfat & ntfs is supported ‘out of the box.’ Something like F2FS has other dependencies. What do you get fr blkid?

Same here, why the critical basic feature like file sharing is removed in the new firmware, is it a joke?! The USB 3.0 port is useless afterwards, not everyone is able to go to ssh to config things, the basic UI is a must. That’s such no brainer and what’s the logic behind such an decision? when will it be added back?


You can install them manually by installing them manually on the plug-ins page

  • gl-sdk4-ui-nasview
  • shadow-useradd
  • samba4-server
  • samba4-utils
  • kmod-usb-storage-uas

or via SSH

opkg update
opkg install gl-sdk4-webdav gl-sdk4-nas-exfat gl-sdk4-nas-utils gl-sdk4-nas-web gl-sdk4-ui-nasview samba4-server samba4-libs samba4-utils minidlna blkid kmod-fs-ext4 kmod-fs-ntfs kmod-fs-vfat kmod-fs-exfat kmod-usb-storage-uas ntfs-3g ntfs-3g-utils dosfstools e2fsprogs shadow-common shadow-useradd

Thanks, it worked for me, please note the MT1300 upgrade itself to 4.3.6 after I turned OFF the autoupdate, not something it should happen,

Good news is that the USB disk write speed trippled from 5MB/s originally to about 15MB/s, not even close to the so called USB3 speed, but much improved. good job

Thank you very much for your replies.

I can mount SD card manually after applied the settings in LuCI again.
And it can share SD card mount point to SMB after configure Samaba4.

And it works also to configure network share using Admin Panel after installed gl-sdk4-ui-nasview.

Although I don’t know why gl-sdk4-ui-nasview is not pre-installed… Anyway, I can get SMB working now.

I use MT1300 Beryl and I can’t install all 5 plugins as I run out of storage on the second one.
Is there any workarounds?
(I updated all the plugins just after the upgrade)

Finally Got this to work, I used 4 of the plugins but now I have no way to set up adguard

  • gl-sdk4-ui-nasview
  • shadow-useradd
  • samba4-server
  • samba4-utils

Probably related:

1 Like

Network Storage can be configured using SSH (samaba4.conf.template) with LuCI (mount point), so if you haven’t enough space for plugins, you need to choose which UI package should be installed.

You can run:

opkg install gl-sdk4-ui-adguardhome

But I guess the flash of MT1300 is too small. You need exroot.