[ Firmware 4.2.0 beta 1 ] Nginx web server doesn't start up after upgrading to (please upgrade to 4.2.0 beta 2 to have it fixed)

After upgrading to firmware 4.2.0 beta 1, the Nginx web server service doesn’t start up after rebooting.

By the way, when I U-boot either 4.1.2 or 4.2.0 beta 1, the update process always failed.

I notice that the downloaded firmware from GL-iNET website, the SHA256 checksum matches with my local checksum utility, however the U-boot MD5 checksum is DIFFERENT with my local checksum utility shows and is changing every time on U-boot web page with the same file.

It’s really weird.


Sorry, it’s browser cache issue, problem solved. :grimacing:

4.2 not working well on ax1800 and mt3000 for me, axt1800 stable so far

My mt3000 upgrade to 4.2.0 beta 1 has nginx web server not starting issue, I still can’t figure it out. :face_with_raised_eyebrow:

Mine can’t start anything, can’t log in to ui

Ya, that’s caused by nginx fail starting issue.

Also experienced the same issue after the upgrade. Seems like something change related to nginx conf/files. Reverted to stable 4.2.1 for now.

1 Like

Yes, 4.2 beta1 snapshot seems broken for BerylAx.

Can confirm the same. BERYL AX MT3000 beta device wont bring up UI nor allow devices connected via ethernet or wifi to go online. Attempted to updgrade to 4.2.0 beta1 3 times and all 3 times this happened.

Reverted to 4.1.2 using debrick via uboot method.

Same issue here on 4.2.0 beta 1.

OK, here we go the new beta 2 firmware.

Download here: https://fw.gl-inet.com/firmware/snapshots/20221229_4.2.0_beta2/mt3000/openwrt-mt3000-4.2.0-1229-1672288172.tar

  • I confirm that the Nginx not starting issue has been fixed.
  • Noticed this indication: (maybe I overlook it before)


  • The “Hardware Accelerator” setting is gone from web UI and need to manually turn on in “Luci → Firewall → General Settings”


1 Like

‘Experimental feature. Not fully compatible with QoS/SQM’

but alas dont think cake sqm is working on mt3000 4.2 beta2

I’m having a weird issue with Wireguard client now:

This is after trying to add a new client to a new group after already having a few set up. I will try to reset to factory and duplicate the issue. I kept settings from update from 4.1.2

Yup, Happened again when I tried to add 2 different Wireguard Configs to the same group.