Firmware release v2.27

Hi All,

We’re glad to release v2.27 except mt300n-v1 and mt300a. Thanks all for testing it and feedback to us on testing phase. Thanks to those who give us great suggestion. We will do well on it. Thansk again!

Release Note

New Feature

  • OpenVPN Server support
  • 3G dongle/LTE auto configuration script support
  • wisp bridge support


  • Security vulnerabilities for gl-web
  • Security vulnerabilities for luci
  • Some other bugs


  • Switch OpenWRT to LEDE source code


It is available on this post. It is convenient to create a customized firmware.

Join in the fun!


My AR300M is running 2.27 testing. The firmware update page shows firmware version 2.27 available but it won’t update the “testing” version?

Also, my B1300 doesn’t show any update available.

If you have upgrade to v2.27 testing firmware, you can’t upgrade online. Download from here. For B1300, we will release it recently, due to it uses qsdk and some bugs to fix.

Am I right to assume that 2.27 is NOT the same as 2,27 testing?


It’s a .bin file, the gl-inet (blue) firmware update page says that the file is not for this hardware. The luci interface rejected it as a wrong format.

The testing version and the previous one are .tar files that I could use?

The correct link for the tar file is

@Glutier The .bin firmware is nor flash firmware.

@glitch Testing firmware will update frequently. It is the same as the latest tesing firmware. Maybe you are use the old one.

my AR300M was working fine in WISP mode, last time it worked was about 20 hours ago. i think the firmware was automatically updated with 2.27… i didn’t make any changes to the configuration.
now the repeater connection stays up for about 15 seconds and disconnects. the auto reconnect does not work.
is it safe to reverse to 2.26x?


update: i’ve installed 2.264 and the connection is stable now.

Need to show change log in these locations:

http:// {router-IP} /html/index?index&firmware_status

I updated to this revision this morning - I wish I hadn’t. It has turned my previously functioning router into a fairly worthless doorstop.

Connect to internet - doesn’t work.
Connect to router interface - doesn’t work.
Use reset button - doesn’t work.
Connect PC directly to router with ethernet cable - doesn’t work.
SSH into router interface - doesn’t work, times out.

I even dismantled the thing and pressed the reset button directly on the mobo - doesn’t work (by which I mean it doesn’t reset it - there are no flashing lights).
I previously had my GL-A300M connected direct to my modem, but now, even connecting it via a router makes no difference, nothing whatsoever works. It shows up in the list of wifi connections, but is impossible to connect to, as is the router interface, it just times out.

I have had to resort to using the crap router supplied by my isp that hasn’t seen any updates in a decade. I would really like my GLI router back, but I have tried everything I can think of, so now it is over to the members of the forum. Please note, there is no use telling me to access the router interface to do anything because I cant.

@viking777 It is failed to upgrade. Pls reading the debricking guide.

@rk47 Will edit it. Thanks.

@pbsnpr v2.27 is recommended. We will check this issue.

Thank you for the link to the debricking guide. I have tried it about a dozen times now, and I cannot get it to work. My problem is that as the GLI router is probably bricked, it cannot create a LAN on its own. The only way to create a lan is to use my old router. Unfortunately this uses for its own interface page, so when I use that address I get the isp routers login page, not the Gli uboot interface, so I can go no further with that procedure unles you know a way around that issue.

If you ever rewrite the uboot interface code maybe it would be a good idea to change its login to a less common address?

Even if you rooter is bricked, you can you boot into Uboot as per the video and load the firmware that way.
You clearly are doing something wrong.

@viking777 It is upgraded on U-BOOT. You should connect your PC to GLI router via cable and set your computer’s IP address to I think you have something wrong.

Thanks for the replies. I had connected my pc direct to the router with an ethernet cable it makes no difference, I do not get the uboot interface because the address it has is the same as the address for my isp’s router interface and that is what loads when I type into my browser.
My pc already has the dhcp address - I cannot remotely understand how changing that to will make the slightest difference, but I am willing to give it a try if you think it matters.

Well, obviously I am completely wrong, changing the pc’s ip address from .3 to .2 does make a difference, I have the modem back again now and connecting to the internet. Albeit the firmware is now at version 2.22 and I am not sure if I want to risk another upgrade to 2.27.
Anyway thank you for your patience and knowledge in helping me, this now appears to be solved.

Well, that success was very short lived.
Firmware 2.22 worked without fault, I decided to try the update to 2.27 again, and it half worked - ethernet was fine wifi was impossible. I spent a very long time trying to make this work without any success, so decided to try a network reset with the reset button (3 seconds). This put the router back to the state it was in when I first posted in this thread (ie. completely dead). I again tried the uboot debrick using exactly the same procedure as before but this did nothing at all and I was again left a dead router. I haven’t got the time to carry on with this game, so I have gone back to the isp router. Obviously I have a major problem with firmware version 2.27, even if others don’t.