First time root password?


When you boot for the first time, connect to wifi with password goodlife and enter web interface, you have to set a new password.

Before setting a new password, i can connect to ssh but can’t enter a valid password.

Once the new password is set in webui, i can connect to ssh successfully.

How can I connect to SSH before setting a new password in the webui? Is there any password set?

I need to login automatically with a script once the router gets an IP with DHCP.


I think you can just press enter and get in ssh, no?

I don’t remember if I tried that, i’m going to check right now.

Yes, i tried, but “Access denied” with blank password.


Nor does goodlife work.

You have to tell me which model and firmware.

I just tried latest firmware and it is OK to login via ssh without password.

It’s GL-S1300 bought 4 months ago, i think Last version but can’t check now.

It’s GL-S1300 v3.105 although version 3.203 it’s available

Version 3.203 has the same result, i cannot enter into SSH without changing the password from the WebUI. neither blank nor goodlife are valid.

can you use telnet? In old openwrt version it use telnet

It works.
Once connected by telnet, it says “Use ‘passwd’ to set your login password!”, so i think ‘root’ does not has password set.