Flint 2 (GL-MT6000 ) - bug reports - collective thread

It is always reachable from LAN, yep.

GL-iNet seems really determined to use the MediaTek proprietary closed-source drivers. User feedback on this forum is pretty clear that there remain significant issues with those MediaTek drivers including on 4.5.8. Personally, I am using the OpenWRT snapshot with a later kernel version than the OpenWRT stable version. The functions I use, work pretty good on that version. Although I do like the GL GUI as that is speedy for setting up the router.

3 Likes

I activated it from the GL.inet interface.
So you’re telling me that SSH is always active on the LAN and that setting on the interface activates it from the outside?

Did you enable it on WAN? Because for LAN it’s always enabled.

1 Like

Here’s the mystery revealed, I was convinced that it was deactivated normally and that setting only activated it on the LAN, I was wrong.
Everything clarified.

You know they going to have two different branches of the firmware right? :thinking:

I decided to give 4.5.8 r1 a shot. So far, so good. I upgraded from 4.5.4 without keeping settings.

Just got this to upgrade from an old but stable Netgear and after putting my port forwards in it asked to update to 4.5.6 which I did.

Now the Port Forwards in Firewall tab are blank but show up via my Phone browser.

Also they show in Luci via my Desktop browser.

Can’t explain it and for some reason the Port Forwards are NOT working.

I’ve seen same phenomen when updated to 4.5.7. Did factory reset and reverted back to 4.5.6, but I cannot get 443 being forwarded to internal nginx (I’ve changed default router ports to 4433 and 880, so
they should not b problematic).

It does not make sense to forward 443 to internal nginx, you can just enable this:

Seems I didn’t explained, I have some services behind unraid server (guacamole etc.).
So I want forward 443 to internal server.

Ah, internal was like “in my network” not “in the Flint2”.

In that case, it should still work straightforward. How did you create the port forwarding?



Wrong topic I guess?

:rofl::rofl::rofl::rofl::joy::rofl::joy::rofl::joy::rofl::joy::rofl::joy::rofl::joy::rofl::joy::rofl::rofl::joy:

Do you want us to understand that… you have installed a snapshot version with the latest kernel and the Italian language? :rofl::rofl::rofl::rofl:

WoW Argon theme :tada::tada:

I have the openWRT Stable running with argon and English if anyone wants to see those screen shots just let me know (jk) :joy: :joy: :joy: :joy: :joy: :joy:

5 Likes

Well I guess I’m back for now. I put the flint2 back online last week with the 4.5.7 and it was stable for 5 days until they pulled it so I decided to try the openWRT stable. 4 days stable so far.
I will say I was able to hit 150 on the 2.4 with 4.5.7 and closed drivers on speed test and iPerf
The open drivers on OpenWRT only topping 100.
Only disconnects are three Tapo L930-5 (tplink) light strips. This happens with open or closed drivers. I have tried everything from turning off AX, enabling legacy B, changing channels, disabling inactivity polling, enabling long pre-emble, disabling low ACK disassociation, changing inactivity limit to longer times, changing from WPA3/2 to WPA2 only.
The only thing I have not tried to changing 802.11w Management from optional to disabled.
It’s only these Tapo TP-Link lights out of 108 clients (95 on 2.4) that are disconnecting that claim to be 802.11b/g/n compatible.
2.5GB iWAN interface seems stable with iPerf running 2.34 Gbits/sec over a 20 foot cable.
I’m starting to think it’s just this brand that’s a TPlink firmware issue. If anyone has any suggestion I’m open to try it. Would like to finally get the Flint2 up and stable with all my devices.

1 Like

ScottD,
I’m running today’s Open-WRT Snapshot with Argon as well :joy:
Have you tried GL.inet’s 4.5.8 BETA? I have a laptop that refuses to connect on OpenWRT using 2.4Ghz and I tried every wifi variation including legacy but no joy (It connects on 5Ghz without issue)…As soon as I tried GL.inet’s 4.5.8 Beta firmware it connected on 2.4Ghz immediately. Of course that’s using GL.inet version of OpenWRT 21.02 but if wifi is really important to you (And from the sound of your network it is) then you should try the 4.5.8 firmware to see if that corrects your problem. I’m back on Open-WRT firmware as I use a wired network and I like the ethernet speed on my Network config.

1 Like