Flint AX1800 how to change port on openvpn server to 443?

i’ve change port in this string. but server doesnt run with same error(port occupied)…

By default openvpn binds to all interfaces. But you really only need this to bind on the wan side. Use the command “local put-your-ddns-name-here” in the server config to do this. Then edit the vpn-service script to not trip that error, and see if it starts.

I did some testing on my router (GL-MV1000W) and got the same results as @pavelgruz.

Unfortunately, the GL.iNet → VPN → OpenVPN Server webpage does not run /etc/init.d/vpn-service directly and calls another function (non-open source in cgi-bin/api???) that gives an error message with slightly different wording.

Instead of clicking on the Start button on the OpenVPN Server webpage, I exited and logged into SSH. I edited /etc/config/vpn_service and changed in the global section:

enabled = 1

When I run the following that had 443 removed, the OpenVpn server started up:

/etc/init.d/vpn-service start

Yes. Pls use try start the service manually.

The UI is stupid.

Server start. it is good. client connect) thanks
but the solution is like a crutch