Flint: cron.err crond[3775] messages repeatedly in log file

Flint: GL-AX1800
Version: 4.4.6

These errors filling my log file, every minute.
I have no modem connected.
Can anyone help figure out what this is and how to stop it?

Thu Oct 19 02:32:00 2023 cron.err crond[3775]: USER root pid 8925 cmd . /lib/functions/modem.sh;check_ip
Thu Oct 19 02:32:00 2023 cron.err crond[3775]: USER root pid 8926 cmd sleep 30;. /lib/functions/modem.sh;check_ip

Thanks

Hi,
Could you reset the router or run the following commands?

uci set system.@system[0].cronloglevel="10"
uci commit system
/etc/init.d/gl_timer restart

Hi,

I’ve rebooted - this is appears to be the default setup with the latest code version.

root@GL-AX1800:~# uname -a
Linux GL-AX1800 4.4.60 #0 SMP PREEMPT Fri Sep 8 06:17:16 2023 armv7l GNU/Linux
root@GL-AX1800:~# uci -N show system.@system[0]
system.cfg01e48a=system
system.cfg01e48a.ttylogin=‘1’
system.cfg01e48a.log_size=‘64’
system.cfg01e48a.urandom_seed=‘0’
system.cfg01e48a.hostname=‘GL-AX1800’
system.cfg01e48a.compat_version=‘1.0’
system.cfg01e48a.timezone=‘EST5EDT,M3.2.0,M11.1.0’
system.cfg01e48a.zonename=‘America/New York’
system.cfg01e48a.log_proto=‘udp’
system.cfg01e48a.conloglevel=‘8’
system.cfg01e48a.cronloglevel=‘5’

I applied the changes that you suggested, looks like that has fixed the logging.

root@GL-AX1800:~# uci -N show system.@system[0] | grep cron
system.cfg01e48a.cronloglevel=‘10’

Thanks

2 Likes

It’s back after a reboot. No big deal but maybe up the logging level on the next firmware.

Tue Oct 24 09:48:00 2023 cron.err crond[3836]: USER root pid 2594 cmd . /lib/functions/modem.sh;check_ip
Tue Oct 24 09:48:00 2023 cron.err crond[3836]: USER root pid 2595 cmd sleep 30;. /lib/functions/modem.sh;check_ip

system.cfg01e48a.cronloglevel=‘10’ is debug; 8 is Normal. You can also set it via LuCI → System → System Properties → Logging.

GL seems to ship stable w/ ‘debug’ still enabled.

1 Like

@fangzekun

Right… so I set cron logging to Warning (9) but I’m showing the same entries every minute.

Can you advise exactly which script is being called that’s hitting the log? I’m not seeing much in /lib/functions/modem.sh.

If you want to set log to 9 and donot want to show that entries,you can run rm /tmp/gl_crontabs/crontabs.d/modem_status_monitor and rm /etc/gl_crontabs/crontabs.d/modem_status_monitor to remove the crond configuration file, and run “/etc/init.d/gl_timer restart” to restart crond. Run cp /rom/etc/gl_crontabs/crontabs.d/modem_status_monitor /etc/gl_crontabs/crontabs.d/ and /etc/init.d/gl_timer restart to recover.

1 Like

Thanks. I just commented out (preceding those lines w/ #) & ran /etc/init.d/gl_timer restart.

That should do it.