Flint (GL-AX1800) Latest firmware

Adguard home should be at your default gateway : 3000 ex (

Hi sorry for the delay yes AdGuard home is there but I find you have to login to the router and then you can find it at

Still getting lockups still haven’t tracked the cause, one thing that has happened since going to Version 4.1.0 is I get strange clients arrive in the Client list managed to take a screenshot this time:

I have had unknown clients with IP address like but the weirdest has got to be the one above.
Any ideas would be gratefully received. is a self assigned IP address. So this seems just a bug. The firmware recorded some info that the client reported by chance. Need to look into it.

Thanks is that one if the reasons it was removed, we’re you aware of random lock ups, it’s seems related to DNS as no browser can access any website on hard wires LAN or WLAN you also can’t get into the routers gui hard reset by power disruption is the only way back into the router, if something is running like an internet radio or if a a download has started it is unaffected, that’s why I point to new DNS requests, I’m Running AdGuard, but I did deactivate it for 24 hours and the same thing happened, I’m also running SurfShark (wire guard) it is very random could happen twice in a day or not for 3 days or so.

I don’t know if this is related, but can you check When Admin panel is too slow or time out - #2 by alzhao

No when it’s running it works fast but a small thing I have noticed with the dark theme selected sometimes it’s half dark and half light and this can be any browser on a wired PC or Wi-Fi laptop or Apple iPad, the dark side (no Star Wars jokes please) is the menu side the light pages are say the VPN Dashboard, I just tried before finding this post and it’s absolutely fine all dark them.

1 Like

There are a lot of topics/threads about the Flint firmware discussing different things like the older kernel at first, the chipset, update problems, uboot, other bugs, etc. It is all very confusing. Every device has bugs but it seems there were unique problems for Flint because it was based on an older software at first, or something like that.

My question is whether all/most of those things are solved. If I buy a Flint now, and update to 4.x according the local upgrade option with uboot image (unless new ones are already on 4.x), then should it be working okay? If Flint is now on 4.x firmware, does it mean that it uses the same openwrt and kernel versions as other newer GL-iNet routers like the Slate-AX (same chipset)?


How do you want to use the router? I use mine as my mainrouter with 3 SSIDs for wifi(regular network, guest network and IOT network) I have adguardhome running OISD fulllist. Running a wgclient. Have about 30 devices connected. I have been running Beta and now snapshot firmware without many issues. Beta firmware I ran for 22days before low memory caused a restart and back up within a few minutes.

Running SAMBA with everthing else running from above
Running wgserver and wgclient with everythnig running above
Speed is 300-350mbps between accesspoints using iperf3, this is down from 600mbps-800mbps I experienced in 3.x firmware

Thanks for the reply. My quesiton is more whether now that Flint is on firmware 4.x, does that mean it’s now using the same openwrt and kernel versions as the other new routers like Slate-AX? Is it still based on that different Qualcomm SDK as is still stated in the store? And the main Flint page still doesn’t mentuon openwrt 21.02 like all the other newer routers.

Hostname GL-AX1800
Model GL Technologies, Inc. AX1800
Architecture ARMv7 Processor rev 4 (v7l)
Target Platform ipq807x/ipq60xx
Firmware Version OpenWrt 21.02-SNAPSHOT r16399+159-c67509efd7 / LuCI openwrt-22.03 branch git-21.284.67084-e4d24f0
Kernel Version 4.4.60

It is not on the 5.4 kernel but slate AX has a old build of 5.4

i have this exact issue, never have this problem on my GL-AX1800 on 3.x firmware, the uboot is on the latest version, and i can’t go back to 3.x firmware.

maybe if some glinet staff can read the logs of our GL-AX1800 to see whats is causing the lockups, mine can lockup anytime, it could be 01 hour usage or 01 day, all of sudden boom: can’t login to gui over wired or wifi, need to unplug power and turn on again.

Gl.iNet staff is on holiday for Chinese new year. It is more then likely no one will respond till next week.

Could you post screenshots of your attempting to load 3.x in uboot? I have upgraded and downgraded on two different flints with out any issue one that is still on uboot 18.

Thanks for the info about the build.

But if I get a new Flint am I likely to have this problem that others are seeing and have to start messing with uboot flashing etc? Or is this only happening in rare specific cases?

I think they ship with 3.214 firmware, I am assuming they will have updated uboot sense I don’t see any notice other then the forums to updated.

I have tried a few things to stop this random freezing, I’ve deleted all the AdGuard block lists and reinstalled them from fresh, I am now trying a different location on my VPN and now waiting if it happens again.
I hope they bring a new model out soon as I do like the router a larger storage with an added micro sd card as well as the USB of cause, and just for the hell of it more LED’s for the LANs especially, that’s just a thing l like doesn’t improve performance obviously.

1 Like

The new Spitz AX (GL-X3000) almost covers that except for lan ports but has a 2.5g

I did notice that but a horrible looking thing LED’s on the top sorry not for me the Flint looks a 1000 times better, they should of stuck with the AX-1800 design.
Don’t like the white colour either.
But thanks anyway.

Radiocrazy, so the problems are so bad with Flint that you think it should be replaced with an updated model? That makes me not want to get one. The specs look really good and like the many LAN ports, but don’t want to have problems with it.