Flint GL-AX1800 Slow Wifi speed

I have setup Flint (after some issues while updating the firmware) and it is now working as a secondary router (not primary beaus of speeds issue).

I have 2both primary and guest ssids (one with vpn the other without, both have enabled adguard) set on a freshly factory reset session.

I have noticed though that the speeds are extremely low (tops 30-40mbps and sometimes upto 5mbps out of a 200mbps connection) on both cases.

Using surfshark wireguard vpn. On pc and phonesame vpn is very fast.

Any ideas on how to fix this? I have searched through the forum and found a couple similar cases but not sure if they are related and about the fix (did not try the dns edit suggested)

Any help is appreciated!


Did you use 5GWiFi for the test? In addition, the use of adguard does affect network performance

Thank you for your reply @luochongjun. I have tried both 2.4ghz and 5ghz. also tried with the same ssid. Adguard indeed causes some delays but never experienced this huge deviation in speed. When I switch from Flint to ISP router the speeds are back to normal. Even with VPN running on each device separately.

Have you ever tried using cable? we can determine if it’s WIFI or not.

I have not measured the connection with ethernet. i will try that and reply tp this thread.

Hi @luochongjun ,
All good now. thanks!
I have measured my speed thru ethernet as suvveated and has been great. Tested on ISP router, then on Flint, then with Adguard then with VPN and lastly both. All worked great with expected results. So, I turned off everything and switched them back on one by one on WiFi while testing speed. I am vetting lower speeds than ISP router but at an acceptable rate.

Thanks for your help!

You can also improve your WIFI connection by adjusting the WIFI channel, transmission power, and bandwidth.