Flint GL-AX1800 wifi networks not seen by some clients

Hi,
I have a GX-1800 configured as a router ethernet connected to a Huawei b818 configured as a cellular modem. Most of my devices connect to the internet fine, but I have one old pc with a TPLink T4UH dual band wifi dongle which can’t see either of the 2.4GHz of 5GHz SSIDs ! Help would be appreciated

Thanks

What is the channel of your AX1800?

Also check the encryption.

Some old devices may not recognize WPA2 and you need to use WPA/WPA2 mixed.
So change the encryption between the options and check.

Hi Alzhao,

I have …

  • the 2.4GHz wifi is on channel 11

  • the 5GHz wifi is on channel 36

  • security for both is set to WPA\WPA2-PSK

the TPLink adapter still can’t see either wifi.

Interestingly enough, the TPLink adapter DOES connect to:

  1. my iPhone 6S plus hotspot wifi (security WPA3 Personal, WPA2 Personal (AES) or WPA2/WPA3 Transitional - according to Apple Support documentation)

  2. my Huawei B818 router modem (security WPA2-PSK)

So I’m at a loss. Connects to two other devices but not the Flint. I think this warrants investigation into the Flint firmware

regards

The problem could also be the channel width.
Some devices can only handle 20 MHz channel widths.

Try to reduce the settings to b/g/n and 20 MHz channel.
If this works, try 20/40 MHz.
If this still works, try using b/g/n/ax
(Spoken for 2.4 GHz only, but try the similar things on 5 GHz)

So you might find the combination that works.

1 Like

In the past I had this problem with my Nintendo Wii. Checked the option “Allow legacy 802.11b rates” in advanced wifi settings solved my problem.

Hi admon. Thanks for the suggestions. I’ll try them. cheers

1 Like

Hi raphamotta. Thanks for the suggestion. I’ll try it. cheers

1 Like

Hi raphamotta, I could not find this setting in the Advanced Settings

Hi admon,
already have the Bandwidth as 20/40 MHz and the Wi-Fi Mode as b/g/n/ax. Does the channel matter at all? Currently have channel 11. Would Auto be better?

Please manually set 20 MHz and b/g/n as suggested.
Those auto settings might be the problem here. AX is pretty “new” and might be not supported.

Mostly auto channel is better, yes.

1 Like

In Luci go to Network → Wireless → Edit on your Wifi network → Advanced Settings

image

Thanks admon. Tried 20 MHz alone. Did not work either.

In the mean-time I have done some experiments:

  1. Connected to two public open wifi (at cafes etc…) successfully. Just could not get an ip address because of the router security settings I suppose.
  2. I have an old NetComm Wireless NB604N DSL Router Modem. The TPlink connects to this also, with ALL of these settings:

channels 1, 6, and 11
bandwidth 20MHz, 40MHz and both
security WPA2-PSK
standard 802.11n

So to me, it seems I’ve tried all combinations with the flint for no result. Are there any other settings I can try? another responder mentioned “Allow legacy 802.11b rates” in advanced wifi settings. I could not find that setting. Is there any way to do this?

Did you tried to lower the WiFi standards to b/g as well?

I have b\g\n\ax on the flint. So unfortunately, yes: includes b and g.

The problem might be, as I said before, the auto setting. Did you tried to reduce the band from b/g/n/ax to f.e. b/g only?

not using the auto setting. Have not tried just b/g. Will give it a go and let you know. Thanks again

hmm so if lowering the cipher does not work, neither the channel as mentoined.

Are you sure your ssid is shown?

Some devices somehow don’t want to connect to hidden ssids.

Also another question does the ssid show up at all?

Also a possibility is if the ssid shows but you get disconnected it might be a dhcp related issue, I got this with my own phone (Poco X3 NFC), it just acts like a wireless deauth but it isn’t because the phone does it.

Also tried setting cipher to psk-tkip and not ccmp?

I know from experience with older devices even with wpa2 ccmp is not always supported.

Thanks admon. The least option available was b/g/n not b/g. Tried b/g/n but still not connecting unfortunately. Do you think we’ve tried eveything possble now? cheers

Yep, now it’s the part where I don’t know any other ways to get it working. It might be some really rare and strange problem. :frowning:

Just to clarify: There is only one of your devices which is not able to see the WiFi at all? Maybe replacing this WiFi dongle should be the best solution then.

I won’t throw it out because it works with all other routers I have tested it with. I think the issue is with the Flint firmware. I could be wrong, but if we’ve exhausted flint config mods and the device works with all other routers i have tested (2 x public wifi + my iphone hotspot), I think that’s ample evidence there could be a problem with the firmware. That said, how do I escalate it to the GLinet team? Or is this enough?