Flint router wifi connection issue

Currently, my Flint router wifi connection often disconnect and reconnect it self within fews second with the latest firmware of 3.207

May I know what is going on?

Do you mean that your pc disconnect from Flint? Or Flint disconnect from your main wifi (as repeater)?

Are you able to get some log from the router? e.g. connect to Flint via ssh and get log using logread

Yes, the device is disconnected from the Flint router within a few seconds then reconnected itself. It’s means offline and online on your device.

However, am not a tech guy so a bit confused about connect to ssh to get a log. BTW, it’s anyway to get a log instead.

I seem to have this to on flint, from what I could see in the logs was only udhcpd renewing leases and then deauthed, but this seems not to happen at all renews.

Though I have wireguard active with mulvads auto config along with nextdns and rebind protections off, could it be caused by a delay?

I use more routers with other qualcomm chips (qca40xx) with vanilla openwrt and smilliar network setup only without the gl software since its not a gl device, but it seems to happen there aswell, I’m starting to wonder if its not some sort of energy saving feature inside the driver.

My wifi ap only drops clients once per 24 hours it could also be 6 hours, and the interval seems to happen consistent aswell it even disconnects when I make traffic at that moment, so it might be either the lease renewal or something in the driver I suspect, does the OP noticed smilliar behaviours or are there commonalities?

And I use 3.207 from the testing folder and I’m not using repeater modus.

1 Like

Hi alannts425:

1, What about LED displays ?
2, Is the SSID of 2.4g or 5G the same?

LED displays is white and the SSID of 2.4g or 5G is different.

Hi xize11:

There is an update to BusyBox. Please help to check if there is still a PROBLEM with UDHCP.
rm /usr/bin/flock && opkg install busybox_1.28.3-4_ipq.ipk
busybox_1.28.3-4_ipq.zip (279.7 KB)

1 Like

You can read logs from Luci.

You can set the WiFi Mode ‘802.11a/n/ac’,and check if that happens again.

My wifi ap only drops clients once per 24 hours it could also be 6 hours.

—》 Is your current device in AP mode?

Noted. I will try it out within this few days again for the connection. However, thanks for your info!

My wifi is in router mode and sending three wireless APs one with 5ghz and ax enabled, the other two are using 2.4ghz (its a custom config, I can add it if you want)

As from the chattyness issue of udhcp I was already looking into it by a different post for busybox 1.28_3-4, but it seems only to partly work, the vlans drop less and wifi aswell, though it still drops, wifi more frequently than vlan, for vlan it seems to drop once per 1-2 days, for wifi its more consisting to 6 hours.


I gonna try to set it on ac mode aswell :+1:

Hi xize11:

Do you have separate vlan Settings?

Nope. This is my 2nd router for vpn connect to main router via ethernet cable.

yup, I add all my configuration files now for wireless, dhcp and network and firewall this config works for me, but it still disconnect me from wifi and also on vlan, I suspect on my setup more issues are able to replicate also for wireguard and stubby, it seems that the daemon command makes all dhcp unresponsive for wireguard when I use /etc/init.d/wireguard restart, it might be that my isp does nightly maintenance and maybe not restart wireguard or stubby properly when mwan3 triggers?

and I used busybox 1.28.3_4 but it seems to still happen also with AC mode.


  • rebind protection is off both on nextdns and router
  • nextdns is active
  • wireguard is active with nl1 config from mullvad
  • did a change to mtu to 1500 inside the wg peer config but that seems not to fix it.
  • changed to AC mode, wireless drop less, but it still drops once per 24h.

Firmware: 3.207 (test build) (Compile time: 2021-11-29 22:17:00)

gl-inet_cfg.zip (3.7 KB)


I might did some interesting foundings, I was searching about issues about mwan3 on the openwrt tracker, there seems to be a bug on some misconfigurations where mwan3 either gets confused which is the wan interface or it doesn’t remember the gateway.

So in this issue they also described that the metrics must be different per interface, and that lan doesn’t need a gateway specified otherwise the wan stats in luci show the wrong wan interface.

Now I also update busybox to 1.28.3_4 and using fw 3.208 snapshot the vlan and dhcp issues seems to be gone when I made these changes, but sometimes my wifi still disconnects but it might be due ax.