FLINT2 (GL-MT6000) Problems after upgrading packages

I had an issue upgrading packages on my router.

I upgrade this list
root@GL-MT6000:~# opkg list-upgradable
lua-eco-mqtt - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-ssl - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-log - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-http - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-socket - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-ubus - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-base64 - 3.2.0-1 - 2023-09-16-4e5411c8-1
lua-eco-dns - 3.2.0-1 - 2023-09-16-4e5411c8-1
Collected errors:

  • pkg_hash_check_unresolved: cannot find dependency libubus20220615 for lua-eco-ubus

But I couldn´t upgrade lua-eco-ubus, but everything seems to work. After the first reboot, I wasn´t able to access admin panel, so I upgrade again the firmware using Luci and now it is working.

The problem is What should I do to upgrade those packages?

Don’t do it.

Upgrading the packages in OpenWrt is not recommend if you are not using the plain OpenWrt firmware.
There are too many dependencies inside the GL packages. It will properly brick your router.

2 Likes