Frustrating VPN Error on AR-750S "WARNING: No internet"


#1

Hi I purchased 10 of these routers for my employees specifically for their VPN functionality.

I want to purchase 20 more but I cannot get the VPN functionality working in our office and this is VERY frustrating.

Every OpenVPN or Wireguard connection attempt results in a “WARNING: No internet” warning. Every LAN client can access the internet just fine, and our LAN clients can even connect to the same exact VPNs fine through the GL.inet router. This is a bug in your software.

Can you completely remove the “WARNING: No Internet” check, and just try to connect to OpenVPN or Wireguard anyways? Or provide an option to disable it? Or give me a custom build so I can buy more of these?

On every single RFC1918 connection I have tried, this error shows even if there is internet access. Here is our exact configuration

WAN IP: 192.168.25.242
WAN Subnet: 192.168.25.240/28

LAN IP: 192.168.8.1
LAN Subnet: 192.168.8.1/24

Tested across multiple networks for two months, reaching out for help. Thank you.


#2

Also please add back two important features from the old firmware:

  • A checkbox to disallow internet access when VPN is disconnected - not always enabled (I do not want to always default true, especially if connecting to corporate private VPN which is not advertising default route)

  • Tailing of the OpenVPN log files

Thank you for your excellent products I have used for years, this new firmware is beautiful design, just needs some quick bug fixes.


#3

Can you put it in the bug tracker? The devs will take a look at it :slight_smile:

Make them separate issues :slight_smile:


#5

Unfortunate.

Okay I submitted some bugs.

The “WARNING: No internet connection” error is the MOST urgent for us, we want to buy more as soon as this is fixed!


#6

Business users do get some priority for feature requests compared to regular customers.
Check back on the status of the bug report and if it’s not fixed, send a message to @alzhao :slight_smile:


#7

It seems that this issue was fixed. Could you please upgrade to the latest testing firmware? http://download.gl-inet.com/firmware/ar750s/snapshots/


Firmware has openvpn problem
#8

I already tried this snapshot and it is now impossible to change servers within the same configuration - it lists servers from another config even though they are correct in /confog/ovpnclients.

As an aside, in my opinion it would be better to list the configs in /etc/openvpn by name instead of ovpn0, ovpn1 etc, as I could only recognize the profile by looking at the password and username combo.