GL-AP1300 LTE "No connection"

I’ve got a GL-AP1300 connected via LTE (working great by the way), but the “Internet” light on the top of the unit next to the power light is not illuminated when connected.

I have this unit on 3.215 Beta3, and working great otherwise from what I’ve tested so far!

Does your network allow Ping?

I can do a test next week to see if it is a problem of wrong LED config.

1 Like

Yes, it can ping, and pass traffic when it works, but led not lit. Attached is a screenshot of my Mudi using the same sim. It works flawlessly, and shows “No Internet” on the device.

Hi,
I have test It.It is OK.

When I disconnect the WAN cable, or boot the unit up and connect using just LTE, the Internet light is off on the top of the unit, but I’ll have connectivity, and the UI will show LTE connection.

Hi,
I checked. This configuration is wrong.You should be configuring it yourself.

@lizh
As soon as I unplugged the ethernet connection, it failed over to LTE, then dropped dead again with “Visible” selected (I’ve tried everything!)

Left it “offline”, no Internet LED while I took my three kids to school.

While gone, it reset a few times it looks like, then suddenly came back online with no intervention. There’s definitely something strange going on here.

Then out of no where, the modem goes into a weird state, and reconnects again, but still no connection.

@lizh @alzhao

I edited the AT+CGDCONT= values in /etc/Visible_profile with the correct information, and placed a # in front of the CFUN=0 and CFUN=1 lines and so far appears to keep this unit online now (without an Internet light illuminated still). It survived a reboot, and power cycle, but will continue testing.

Removing the hashtags in front of CFUN=0 and CFUN=1 in “/etc/Visible_profile” allows the correct APN (once edited) information to be written shown below upon a powercycle/reboot, and eliminates any of the verizon nonsense (which is where I think the issue lies)

at+cgdcont?

+CGDCONT: 1,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 2,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 3,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 4,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 5,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 6,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

Hi,
1,This configuration is incorrect.
Please restore the modem first.The APN configure as follow:
‘AT+CGDCONT=1,“IPV4V6”,“VSBLIMS”’
‘AT+CGDCONT=2,“IPV4V6”,“VSBLADMIN”’
‘AT+CGDCONT=3,“IPV4V6”,“VSBLINTERNET”’
‘AT+CGDCONT=4,“IPV4V6”,“VSBLAPP”’

2,It used a third way APN dial with visible.
3,Frequent ping operations are not allowed for Visible.

I reset the modem, and set Visible_profile to your settings, and power cycled.

at+cgdcont? shows:

at+cgdcont?

+CGDCONT: 1,"IPV4V6","VSBLIMS","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 2,"IPV4V6","VSBLADMIN","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 3,"IPV4V6","VSBLINTERNET","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 4,"IPV4V6","VSBLAPP","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 5,"IPV4V6","vzwemergency","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1
+CGDCONT: 6,"IPV4V6","VZWCLASS6","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

What in the world do you mean frequent ping operations are not allowed for Visible? I’m sending 1PPS 32b ICMP. Are you saying they’re going to flag that as network abuse?

@lizh
Internet LED, still not lit but I have connectivity for the time being.
goodcloud_disconnected
Logged into goodcloud, and shows "Disconnected’ under cellular (the only way this AP1300 is connected right now).

Yes. This seems the case for Visible.

Do you use vpn on the router? If not maybe just a bug.

No, not currently. I reset the modem using AT+QPRTPARA=3, then factory reset the AP1300. Set the APN to Visible/VSBLINTERNET, MTU to 1428, and used a firewall rule to set TTL correctly.

Thank you very much for your feedback.
Since ping is disabled for Visible. So here the network is judged disconnected, but it’s actually normal.

Yes, it will be flagged as Internet abuse.

So, I give a conclusion:

  1. Firmware 3.215 snapshot (newer than beta3) fixed the problem which only affect AP1300.
  2. You have to select profile “Visible” to use Visible network. Do not configure manually.
  3. Visible has some limitations so we disabled ping in this interface intentionally. So it report “Disconnected” on Goodcloud but everything is working fine. We will not fix this recently in 3.x firmware because we already moved forwarded to 4.x firmware.

I just received a new sim card on Visible’s “$30 a month” plan and popped it in the AP1300. Auto setup (vzwinternet APN) worked like a champ, and now have an Internet light illuminated. Testing stability now, and am still using my ‘old’ party pay plan Visible connection in my E750.

1 Like