GL AR-150 Unstable Connection to Laptop

Hi all,

I have just tried connecting my new laptop to my GL Inet 150 Router.

I found out that my laptop to GL Inet router is very unstable compared to when connecting via my brother’s wifi at home.

Two things to note are:

  1. When connecting to the home router, my laptop to home router connection is very stable.

  2. When I tried connecting my modem directly to my laptop, the connection never drops.

  3. I had my GL AR-150 Router reset and then set up again.

Why can it possibly happen? It is so weird

Thanks all for your attention to my problem. Peacee :slight_smile:

Is AR150 connecting as repeater?

When this happens, can you get the logs? You can go to advanced settings, then status, system log.

No, the router is used as a tethering device. A modem is attached to the router. The router is used to spread wifi.

will get to the log. Thankss

This is the log attached :slight_smile:

From the log it seems caused by ipv6.

Can you disable ipv6 on your pc? Or can you try 3.105 firmware which disabled ipv6 by default.

I have disabled ipv6 on my pc. Will report on the result. Thankss

Andd… Do you have 3.105 firmware just in case? :smiley:

I have disabled ipv6, but the connection keeps dropping :frowning:

I have attached the system log again.

Do you know why is this happening? Hehe


Can you just try the snapshot here GL.iNet download center

Seems the laoptop disconnect actively and the router didn’t report anything.

Can you change channel and encryption of the router an try?

Okay. Which one should I choose @alzhao?

The link you provide gives the firmware. Should I install it later?

This one GL.iNet download center

I suggest you try to change wifi encryption (WPA WPA2 ) and try

I have changed my wifi encryption from WPA2PSK to WPA/WPA2PSK but still disconnecting…

SYSTEM LOG (623 Bytes)

If i change the 3.107 firmware to 3.105 firmware, could it stabilize my connection to the router @alzhao?

Maybe not. As you said it is new laotop, I assume it should have new wifi chip and should not have capability issues like old wifi chip. Sorry I don’t have a clue.

actuallly it is a second laptop… a Thinkpad T460 with Intel Dual Band wireless AC 8260…

i think if the problem is rooted in ipv6, i will try disabling by downgrading firmware from 3.017 to 3.015. Is it basicly safe?

1 Like

The latest snapshot should be 3.105, upgrade, not downgrade

This is my current firmware 3.017… Can I drag and drop the 3.015 firmware?

Yes. I think so. Go to “Local Upgrade” and drag and drop the firmware.