GL-AR150 mt7601 wifi dongle

 

please help install wifi dongle chipset mt7601 in GL-AR150

 

 

From https://github.com/porjo/mt7601

Now that Kernel 4.2 has been released which contains a driver for mt7601u, this repository is now deprecated.

So this means that OpenWrt trunk (DD), which is using Kernel 4.3 should support this one.

If you can try the new firmare from Index of /snapshots/trunk/ar71xx/generic/, that would be good. Otherwise we have to compile the kernel module fro CC1505 (Kernel 3.8)

alzhao

Hello, yes is work, no connecting network, please compile for CC1505 me testing

@saimonyz

Can you please confirm that the trunk image you loaded does or does not include LuCi?

OpenWrt default images do not include wireless enable or configured. Have you tried to click the “ADD” button for radio 0 and manually enter the information to configure your WLAN connection. Make sure you select LAN in the Interface Configuration section. There should not be a WLAN there as your LAN port and WLAN are bridged, and the default config is called LAN.

Otherwise you need to post more info for help. I do not think it’s an image issue, just some missing config.

@RangerZ

me ar150 firmware 2.13 setting in reapeter mode my copie etc\config\ firewall wireless network …

my instal Openwrt DD version open winscp and replace config in etc\config\ restarting router

connecting putty opkg update,install luci,and kmod-7601u restarting router

open web router interfaci luci

@saimonyz, as RangerZ said, the firmware is working. You can try to config it using the image now.

Don’t copy your old config to the new one.

In the Luci interface you posted, seems you already configured Radio1 as repeater, now you need to add one interface for Radio0. Just click “Add” on the right of Radio0 to add one interface.

@alzhao

radion0 repeater is work connecting network internet available
radion1 repeater not work no connecting network no internet

dmesg

Based on this post it appears you have a working WWAN side. 404 Page not found - GL.iNet

I assume you are connected on the LAN side via Ethernet. The basic issue 'appears" to be you have not (not able??) to configure the WLAN side.

Please use a tool like WinSCP to find and post you /etc/config/wireless and network files.

In LuCi if you go to Network=> Diagnostics=> ping do you get a reply?

I expect radio1 can reach the internet, and radio 0 is not working (WLAN)

pls post your content of /etc/config/network and /etc/config/wireless, remember to remove your passwords

@alzhao

wireless

config wifi-device ‘radio0’
option type ‘mac80211’
option hwmode ‘11g’
option path ‘platform/ar933x_wmac’
option htmode ‘HT20’
option txpower ‘18’
option country ‘US’
option disabled ‘0’
option channel ‘1’

config wifi-device ‘radio1’
option type ‘mac80211’
option hwmode ‘11g’
option path ‘platform/ehci-platform/usb1/1-1/1-1:1.0’
option htmode ‘HT20’
option channel ‘1’
option country ‘US’
option txpower ‘30’
option disabled ‘0’

config wifi-iface
option network ‘wwan’
option ssid ‘Stantion74’
option encryption ‘psk2’
option device ‘radio1’
option mode ‘sta’
option bssid ‘BC:F6:85:43:1E:E2’
option key ‘samplepassword’

config wifi-iface
option device ‘radio0’
option mode ‘ap’
option ssid ‘OpenWrt’
option network ‘lan’
option encryption ‘psk-mixed’
option key ‘samplepassword’

network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd54:1f13:94e3::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth1’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option ipaddr ‘192.168.2.1’

config interface ‘wan’
option ifname ‘eth0’
option proto ‘dhcp’

config interface ‘wan6’
option ifname ‘eth0’
option proto ‘dhcpv6’
option type ‘bridge’

config interface ‘wwan’
option proto ‘dhcp’

From you config,

Radio1 is repeater and it has connected to your main router.

Radio0 is AP and you should connect to ssid “openwrt”.

If you have no Internet when you connect to “OpenWrt”, seems that the firewall is not correct. You created “wwan” and need to add this to your firewall.

Pls also give the output of “ifconfig” and content of “/etc/config/firewall”

@alzhao

firewall

config defaults
option syn_flood ‘1’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘REJECT’

config zone
option name ‘lan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
option network ‘lan’

config zone
option name ‘wan’
option input ‘REJECT’
option output ‘ACCEPT’
option forward ‘REJECT’
option masq ‘1’
option mtu_fix ‘1’
option network ‘wan wan6 wwan’

config forwarding
option src ‘lan’
option dest ‘wan’

config rule
option name ‘Allow-DHCP-Renew’
option src ‘wan’
option proto ‘udp’
option dest_port ‘68’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-Ping’
option src ‘wan’
option proto ‘icmp’
option icmp_type ‘echo-request’
option family ‘ipv4’
option target ‘ACCEPT’

config rule
option name ‘Allow-IGMP’
option src ‘wan’
option proto ‘igmp’
option family ‘ipv4’
option target ‘ACCEPT’

config rule
option name ‘Allow-DHCPv6’
option src ‘wan’
option proto ‘udp’
option src_ip ‘fc00::/6’
option dest_ip ‘fc00::/6’
option dest_port ‘546’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-MLD’
option src ‘wan’
option proto ‘icmp’
option src_ip ‘fe80::/10’
list icmp_type ‘130/0’
list icmp_type ‘131/0’
list icmp_type ‘132/0’
list icmp_type ‘143/0’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-ICMPv6-Input’
option src ‘wan’
option proto ‘icmp’
list icmp_type ‘echo-request’
list icmp_type ‘echo-reply’
list icmp_type ‘destination-unreachable’
list icmp_type ‘packet-too-big’
list icmp_type ‘time-exceeded’
list icmp_type ‘bad-header’
list icmp_type ‘unknown-header-type’
list icmp_type ‘router-solicitation’
list icmp_type ‘neighbour-solicitation’
list icmp_type ‘router-advertisement’
list icmp_type ‘neighbour-advertisement’
option limit ‘1000/sec’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-ICMPv6-Forward’
option src ‘wan’
option dest ‘*’
option proto ‘icmp’
list icmp_type ‘echo-request’
list icmp_type ‘echo-reply’
list icmp_type ‘destination-unreachable’
list icmp_type ‘packet-too-big’
list icmp_type ‘time-exceeded’
list icmp_type ‘bad-header’
list icmp_type ‘unknown-header-type’
option limit ‘1000/sec’
option family ‘ipv6’
option target ‘ACCEPT’

config include
option path ‘/etc/firewall.user’

config rule
option src ‘wan’
option dest ‘lan’
option proto ‘esp’
option target ‘ACCEPT’

config rule
option src ‘wan’
option dest ‘lan’
option dest_port ‘500’
option proto ‘udp’
option target ‘ACCEPT’

ifconfig

from “ifconfig”, you don’t have IP address assigned for your wlan0 or wlan1, one of which (should be wlan1) is the sta interface. It means that DHCP is not successfully in this interface.

I don’t know why, but the firewall seems just fine.

Maybe there is a bug in this bleeding edge firmware. Can you show output of “ps -w”?

Does your main router support DHCP?

 

@alzhao

you posible compile module fro CC1505 (Kernel 3.8) ?

Cannot see any problem.

Maybe last try:

/etc/config/network

config interface ‘wan’
option ifname ‘eth0’ #remove this line
option proto ‘dhcp’

 

/etc/config/wireless

config wifi-iface
option network ‘wan’ #change “wwan” to “wan”
option ssid ‘Stantion74’

Then reboot