GL-AR150: web interface stuck loading

I just got a brand new GL-AR150, and I connect to the SSID with the correct password, then try to navigate to the web interface. I see the HTML load (the debugging panel is showing that), so it looks like I can talk to it. But the page remains blank/white. I tried Firefox and Chrome. Seems like it is stuck somehow.

On Firefox I see this error:

Invalid X-Frame-Options: “DENY; Content-Type: text/html; charset=utf-8” header from “HTTPCOLONSLASHSLASH192.168.8.1/” loaded into “HTTPCOLONSLASHSLASH192.168.8.1/”.

On Chrome I see this error (it’s actually paused in the debugger):
config.js?rev=dsa1d4123115541581234qw1eqw1433d41dasd:199 Chrome: 79.0.3945.88
require.js?rev=dsa1d4123115541581234qw1eqw1433d41dasd:5 GET net::ERR_ADDRESS_UNREACHABLE

Tried my android phone, same thing, partially loads but the web page gets stuck.

I haven’t touched any setting, or anything. This is straight out of the box. What the heck am I doing wrong?

FYI, it wouldn’t let me post this (as a new user) due to more than two URLs, so I had to replace them with HTTPCOLONSLASHSLASH…

Follow the guide here:

Use the latest firmware from here:

Wow, that fixed it indeed. Bricked right out of the box, impressive. I guess there’s a first time for everything… Thanks!

You are welcome :slight_smile: And yeah it can happen.