GL-AR300M and HUAWEI E3372h-153 Hilink Stick

Hello Support Team,

i have an GL-AR300M Mini Router for my caravan. I want to use addional an 4G LTE stick. I got an Huawei E3372h -153 stick with Firmware above 22.x. That means that the stick has a HILINK Firmware. Can anybody help me to get it working? Out of the box, it dos not work.

 

Thank you Matthias

If it is hilink then it should be easy. Did you find it as a device in “Tethering” tab in Internet settings?

I just updated the docs here: http://www.gl-inet.com/docs/mini/3g4g/

Hi alzhao,

thank you for your response. I tried it but it dosn’t work.

I see only the message “no phone device connected” if i plug in the stick.

In the “3G/4G” Menue, the message is " Please plug in your modem"

 

Can anybody help me ?

 

Thanks Matthias

are you using the newest firmware? Can you go to advanced settings and get the system log and kernel log.

Hi alzhao,

 

i used the lasted Version 2.63. At the third time aof startup i find in the register “tethering” the “eth2” interface. When i connect to ths interface i can see for one moment

that i get the ip 192.168.8.100 but i dosn’t can reach the internet. Also i dosn’t can reach the web interface from the LTE stick. I think i had i to found it under the new IP 192.168.8.100.

But i can’t reach it.

 

Attached is hier the Syslog and the Kernel Log:

 

Thank you for your help.

Matthias

 

 

Might be way off here, but isn’t this the problem (previously discussed in the forum) of an IP conflict (both modem and router trying to allocate 192,168,8,x?
Apologies if I’m talking nonsense.

Glitch.

Yes, that is the problem.

Change the LAN Ip of the mini router to 192.168.9.1 or some thing else to avoid conflict with 8.1

Hi, thank you both for your replay.

I changed the IP adress from the router to 192.168.9.1 but it dosn’t solve the problem.

I can see the eth2 only sometime for a few seconds.

Has anyone one more idea?

 

thank you

Matthias

the Logs are new after the change to 192.168.9.1.

 

 

Seems the dongle kept to register and unregister. This seems a power issue.

Pls try a more powerful power adapter.

Hi,

i tried it with my new handy charger. It is a 5V 2A Charger. The result is the same. Is more than 2A needed? What do you mean?

Have a nice day.

Matthias

I came to this thread because I have exactly the same issue. Most recent firmware, same LTE stick, also running with HiLink. Also moved the network from the AR-300M to 10.0.1.1 to don’t get the conflict. In the control panel I can see the connection is established, bit it seems that it isn’t shared correctly neither via LAN nor via WLAN.

For upcoming firmware versions it would be really great to have some visual way of defining which kind of input should be available on which output :slight_smile:

I can confirm this is a power issue I used a 5v powered hub and that solved the disconnection problem, I then had to manually bridge the interfaces using the ‘advanced’ option.

before starting ensure that your stick and router are on separate ip ranges as they come on the same ones by default. I set the stick to 192.168.7.*

from normal user interface click on advanced, log in, from the top menu select ‘Network’ then ‘Interfaces’ then click ‘edit’ on the ‘Tethering’ section then click on the ‘Physical settings’ tab and put a tick in the box at the top ‘Bridge interfaces’ then in each of the boxes for eth1, eth2 and ‘Wireless network’ (Wlan) this will link the 4G stick to the LAN port and the WiFi

I confirm the information in this thread to be helpful.

I had the same problem and found a solution here.

My “Huawei e3372h-153” after connecting it to the GL.iNet router in “Theter” mode (as 3G/4G is not available) was rising warning that IP 192.168.8.1 is in conflict. I confirmed that both GL & Huawei were using it by:

I went in GL admin panel to “MORE SETTINGS > LAN” and this message was displayed:

GL routers use 192.168.8.1 as the default LAN IP address. This is the address you would enter into your browser 's address bar to access the router admin page. You can manually setup one within these three ranges:192.168.x.x , 172.x(16-31).x.x or 10.x.x.x

Note: The starting IP address and ending IP address must be in the range of 2~254, and the ending address should be greater than starting address.

Setting that was not working:
LAN 192.168.8.1 - default
LAN 192.168.8.2 - that’s what I tried first

Solution - setting that worked:
LAN 192.168.7.1

My perspective of this situation as a user:
I wish the “Thetering of some 4G USB routers instead of ‘3G/4G USB router’ option” was explained a little bit more in the manual. And that IP confing too - like I’ve changed LAN 192.168.8.1 to LAN 192.168.8.2 and it was no working but LAN 192.168.8.1
LAN 192.168.7.1 worked and I do not understand why there were separate adressess after all!

On the topic of power:
I unplugged GL router from USB PC and plugged it to my smartphone charger. But this did no effect. When setting the above LAN IP options it works just fine connected to USB 3 PC (but to a smartphone charger as well). I think people rising problem with that were using older USB that had less power.

/

Big thank you all for your help! GL.iNet routers are the best!

/

Versions:
GL-MT300N-V2
Huawei USB modem hardware version: CL2E3372HM
Huawei USB modem software version: 22.200.09.00.1202
Huawei USB modem www interface version: 17.100.11.00.1202

1 Like