GL-AR300M Lite solid red light


#1

So I ran into some trouble getting open vpn working with my home router, I uploaded the files to GL router and couldn’t connect with fatal error, so I tried to load a new firmware, apparently it was a wrt and it was much more complicated than I wanted vs stock. Now I’ve tried to revert back by flashing FW but now I think it’s bricked as it only has the red power light on and nothing else, reset does nothing, holding reset for 10 seconds gives a green flash on lights and then nothing but the solid red, no ssid shown in connections. I don’t have facebook so I wasn’t able to get into a chat for help on their website.


#2

I was able to get into the u-boot menu and flash firmware with that, looks like it’s back up.


#3

Do you solve the problem?


#4

Yes, at first it wasn’t working to flash with u-boot, in their video it shows setting static ip on computer to 192.168.1.2 and subnet to 255.255.255.0 and then it skips to log in to 192.168.1.1 browser but it doesn’t show to add under default gateway in ipv4 settings it also needs the 192.168.1.1 set there too, also it wasn’t clear that you can use the wan port( as it’s the only rj45 on this model) and to connect directly to computer adapter.
I found that the latest firmware on the site for this router under test folder bricks it and does not flash properly. I had to resort to an older firmware in the v1 folder. After successfully flashing with u-boot and reloading it came up properly, It seems to go directly to the advanced menu and skips the gui skin they have, I ended up getting to it with 192.168.8.1/?
Then I was able to auto update firmware to latest in the simple gui menu

I also got the vpn client working, I had to load the config file my router (netgear nighthawk r7000) had setup for phone as the windows and other config files did not work, I tried editing the windows .ovpn and kept getting fatal errors for connection after every new error got fixed adding new lines so I remembered seeing the .ovpn config when I setup on my android, loaded up and works great, I also like the feature of being able to turn it on and off with the side switch on the GL router.
I didn’t really have a serious need for the vpn client on router as I have it configured on my phone and laptop to connect to home but eh I’m a sucker for needless tech.
Just in time for my trip Sunday. I only got this router so I can use my chromecast without broadcasting it’s existence on the hotel wifi, last trip I took some joker kept connecting to it and casting porn to it while I was trying to netflix.


#5

So after reading about openwrt it seems that the last time I flashed firmware when I thought I bricked it, I had set it to forget settings so I’m thinking that the green light was off because wifi was disabled by default by openwrt.
I never thought to try and connect on the wan port.