GL-AR300M NAND - Can't access wifi any longer but to reboot the device


I use both GL-ARM300M NOR and GL-ARM300M NAND with 3.211 software version as access points for my personal network. GL-ARM300M NAND is wired-connected to my internet router via an ethernet switch. The internet router handles a DHCP server.

While I see no issue with GL-ARM300M NOR access point, I’ve got a recurrent issue with GL-ARM300M NAND where I observe internet traffic on devices connected through the access point becomes very slow, and additionally wifi authentication systematically fails. This is solved after reboot but aims to reoccur after few times (I estimate after 2-3 weeks).

I’d like to investigate the issue to solve it for good. Can you please help me discriminate the problem and use the right tool into OpenWRT environment to find out the root cause?

1 Like

Can you post the portions of the System Log and Kernel log before/after the problem?

If the issue is fixed after reboot and the issue repeats itself once every 2 weeks, then use a smart plug (schedule the smart plug to restart itself once per day)

Please have both System Log and Kernel Log for GL-AR300M before issue:

Once the issue reoccurs, I’ll post both the logs to describe the problem.
[Edit] the issue reoccured on February-17. Please see the posts below.

Does the device work in router mode? i.e it create a separate subnet than your main router?

AR300M and AR300M16 should not be different in these setup.

The device runs in Access Point mode. It doesn’t manage IP addresses as DHCP server runs on my internet router. So devices wired-connected to the router (NAS, computer…) share the same subnet with those wireless-connected (laptop, mobile phone) through the access point.

AR300M and AR300M16 should not be different in these setup.

I’ve checked settings in Luci UI for both GL-AR300M NAND and GL-AR300M NOR. They have the same but on channel (I manually force channel 1 for NOR and channel 8 for NAND).

Just want to make sure you set up AP mode in the web panel->network mode->AP mode, not setting subnet etc manually, right?

To sum-up my network configuration:

  • Internet Router
    • GL-AR300M NOR
    • Ethernet Switch
      • GL-AR300M NAND

Both GL-AR300M NOR and NAND share the same Wifi SSID and password. So user automatically connects (and switches as needed) depending on connection quality between both the devices.

This February-17, the issue shows up once more on GL-AR300M NAND. I observe:

  • User can’t see anymore Wifi network provided by GL-AR300M NAND in the list of available wireless networks. I deduce the device doesn’t spread any info anymore over-the-air. (Even if SSID was hidden, I expect the user can still detect and connect as network details were priorly saved as favorite. But that’s not the case)
  • It seems remaining wireless connections weren’t abruptly shutdown. The device disconnected users based on the expected inactivity time out.

Please have below the links to System Log and Kernel Log:

I can’t find any issue there. You can see the device stopped receiving connection requests from users on February-17.
So I’m looking for a cause why GL-AR300M NAND doesn’t publish its wireless details over-the-air.

For info, please have below the wireless config:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ahb/18100000.wmac'
    option htmode 'HT40'
    option txpower '20'
    option txpower_max '20'
    option band '2G'
    option country 'FR'
    option channel '8'
    option noscan '0'
config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option wds '1'
    option disassoc_low_ack '0'
    option ifname 'wlan0'
    option ssid 'freebox_******'
    option key '************************'
    option encryption 'sae-mixed'
    option ieee80211w '1'
    option ft_over_ds '1'
    option ft_psk_generate_local '1'
    option mobility_domain 'e5e7'
    option ieee80211r '1'
config wifi-iface 'guest2g'
    option device 'radio0'
    option network 'guest'
    option mode 'ap'
    option wds '1'
    option ssid 'GL-AR300M-f01-Guest'
    option encryption 'psk2'
    option key 'goodlife'
    option ifname 'wlan1'
    option disabled '1'
    option guest '1'
    option flag '1'

Hi alzhao,
The device does run in AP mode.

I additionally notice Luci interface shows no power on Wifi network wlan0:

Thinking of the Wifi chip to be out of power, I’ve just tried to have the device scans wireless interfaces in Luci by clicking on Scan in front of radio0. It seems it powers up the radio chip again and wlan0 is now available again.

I notice both the devices have different packages installed while they use the same radio chip QCA9533.

  • GL-AR300M NOR has ath9k packages installed (e.g. kmod-ath9k)
  • GL-AR300M NAND has ath9k and ath10k installed (e.g. ath10k-firmware-qca9887, kmod-ath10k, kmod-ath9k)

Can you please help to check whether such issue may come from this difference in packages?

Saw from your settings you are using wpa3.

Can you change to wap2 and check in case this is the problem?

The “Status” page shows the signal. But I guess that it will only show one value if you have device connected to the wifi. Otherwise it will show as 0.

Hi alzhao,

Can you change to wap2 and check in case this is the problem?

I’ve just changed encryption mode from WPA2/WPA3 to WPA2. I’ll check whether the issue reoccurs.

The “Status” page shows the signal. But I guess that it will only show one value if you have device connected to the wifi. Otherwise it will show as 0.

That makes sense. Because none of my phone was wireless-connected, then it showed 0.

Hi silkweb,
I can actually design a software solution in the access point (e.g. having a cron task to reboot the device).
My point in this thread is to understand the cause why the device is abruptly not accessible anymore for Wifi client.

Hi alzhao,

The issue just occurs. My laptop and mobile phone can’t detect GL-AR300M NAND specific wireless network any longer.

To summary: AR300M with firmware 3.211, works in AP modem and wifi may disappear for no reason. No related logs.

Let me put one arouter like this and see if it happens here.

Please let me know if you need additional setting details to reproduce a twin of my device.

Currently I only observe the issue from Client point of view. I.e. My laptop can’t see the wifi network any longer. As I check the access point, there is no alert saying there is something wrong. Can I have the possibility to get the modem status and statistics in the access point? By this way, we may figure out what the problem is.

Comparing to my GL-AR300M NOR, I’ve just removed extra packages I had in GL-AR300M NAND (such as ath10k-firmware-qca9887). I’ll see whether this change the issue.

Please don’t do this because it may cause wifi interface change.

This didn’t solve the issue.
Once more today, I can’t see GL-AR300M NAND wifi network anymore on my devices.

Following this last occurence,

  • I’ve just reverted GL-AR300M NAND firmware to its factory state.
  • I’ve changed network mode to Access Point
  • I’ve changed TimeZone to Europe/Paris
  • I’ve modified Wireless settings so it matches to my network (changing SSID, security method, password, channel)

Even if Luci UI is installed, I didn’t use it for this fresh configuration.
Let’s wait for some days whether the issue happens again.