GL-AR300M Shadow 4.3.7 Repeater-Extender mode

Hey, just wanted to start a thread for anyone using the GL-AR300M Shadow running firmware 4.3.7 (which is now considered stable!) in Repeater mode, specifically, Extender mode of Repeater mode.

The mode works, but I have noticed that Shadow’s own wifi network seems to disappear from the available wifi SSIDs reported by my devices quite often while in this mode, for what seems like a few minutes at a time, even though I can still reach devices on the other side of the Shadow from its uplink network.


  1. The goal is to have all devices share the same network, the house wifi’s network of 192.168.5.x.
  2. I put Shadow in Repeater-Extender mode, with the house wifi network for its uplink.
  3. I connected several devices to Shadow thru its LAN port
  4. Shadow, and all devices connected thru its LAN port, either get DHCP from the uplink DHCP server, or have static IPs in the host subnet (everything is set up to use uplink’s settings of 192.168.5.x)
  5. when Shadow is connected and Repeater-Extender mode is up, I can pretty reliably talk to all the devices behind Shadow from the uplink network… not many glitches
  6. Shadow’s own wifi network disappears from available wifi SSIDs fairly often for minutes at a time
  7. meanwhile, I can still talk to the devices behind Shadow from within the uplink network

So far, I haven’t characterized the behavior when devices are connected to Shadow’s wifi yet … only with devices connected thru the LAN port and nothing on Shadow’s own wifi network.

In general I’ve noticed 4.x firmware on my GLi devices to have pretty frequent dropouts of their wifi SSID from the available list when they are in repeater mode, even though an actual connection to the GLi devices once established is fairly stable (though not rock solid). But, the issue is very very noticeable with Shadow running 4.3.7. So I thought I would start a thread.

A presumably separate issue, but it appears Multicast DNS / mDNS / Zeroconf / Avahi / Bonjour does not work across the bridge in Repeater-Extender mode.

(Repeater-WDS mode does not work with the uplink wifi network I am using.)